Bug 668602 - F15 - amarok - crash
Summary: F15 - amarok - crash
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: amarok
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 667365 669364
Blocks: F15Blocker-kde
TreeView+ depends on / blocked
 
Reported: 2011-01-10 21:10 UTC by Flóki Pálsson
Modified: 2011-01-15 22:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-13 21:16:01 UTC
Type: ---


Attachments (Terms of Use)
Form Amarok - The KDE Crash Handler (5.49 KB, text/plain)
2011-01-10 21:10 UTC, Flóki Pálsson
no flags Details

Description Flóki Pálsson 2011-01-10 21:10:34 UTC
Created attachment 472693 [details]
Form Amarok - The KDE Crash Handler

Description of problem:
Not possible to start amarok. 

Version-Release number of selected component (if applicable):
amarok-2.3.90-3.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1.  start amarok form terminal
2.
3.
  
Actual results:
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kbuildsycoca4 running...
unnamed app(2594): Communication problem with  "amarok" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.ServiceUnknown" : " "The name org.kde.amarok was not provided by any .service files" " 

KCrash: Application 'amarok' crashing...
KCrash: Attempting to start /usr/libexec/kde4/drkonqi from kdeinit
sock_file=/home/floki/.kde/socket-flokir/kdeinit4__0

Expected results:
To see amarok 

Additional info:
See attachment  Form Amarok - The KDE Crash Handler 

not possible to use Amarok - The KDE Crash Handler 
An error was encountered during the installation of the debug symbol packages.

Amarok was runing fine in F15 before.  
That is amarok-2.3.90-2.fc15.x86_64.

Comment 1 Rex Dieter 2011-01-13 13:15:49 UTC
"Before" is likely prior to updating to mysql-5.5

Comment 2 Kevin Kofler 2011-01-13 21:16:01 UTC
This got fixed by the fixes for bug #667365 and bug #669364.

Comment 3 Clyde E. Kunkel 2011-01-13 22:46:29 UTC
Did it get fixed?  Maybe not.


[kunkelc@P5K-EWIFI ~]$ uname -r
2.6.37-2.fc15.x86_64
[kunkelc@P5K-EWIFI ~]$ rpm -q mysql amarok
mysql-5.5.8-4.fc15.x86_64
amarok-2.4.0-1.fc15.x86_64
[kunkelc@P5K-EWIFI ~]$ amarok
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work 

(<unknown>:13228): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed
mysql_embedded: Table 'mysql.plugin' doesn't exist
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use GCC atomic builtins
InnoDB: Compressed tables use zlib 1.2.5
110113 17:45:36  InnoDB: Using Linux native AIO
110113 17:45:36  InnoDB: Initializing buffer pool, size = 128.0M
110113 17:45:36  InnoDB: Completed initialization of buffer pool
110113 17:45:36  InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name /var/lib/mysql/ibdata1
InnoDB: File operation call: 'create'.
InnoDB: Cannot continue operation.
unnamed app(13227): Communication problem with  "amarok" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.ServiceUnknown" : " "The name org.kde.amarok was not provided by any .service files" "

Comment 4 Tom Lane 2011-01-13 23:12:04 UTC
you need mysql-5.5.8-5 to have both fixes.

Comment 5 Flóki Pálsson 2011-01-15 22:57:32 UTC
OK now 

amarok-2.4.0-1.fc15.x86_64
$ rpm -qa | grep mysql
mysql-libs-5.5.8-5.fc15.x86_64
mysql-embedded-5.5.8-5.fc15.x86_64


Note You need to log in before you can comment on or make changes to this bug.