This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 668607 - CoreGUI: alert def unit parsing and conversion needs some work
CoreGUI: alert def unit parsing and conversion needs some work
Status: CLOSED DUPLICATE of bug 698600
Product: RHQ Project
Classification: Other
Component: Alerts (Show other bugs)
4.0.0.B02
Unspecified Unspecified
high Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-10 16:25 EST by Jay Shaughnessy
Modified: 2011-08-12 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
All
Last Closed: 2011-08-12 12:34:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2011-01-10 16:25:21 EST
We need parity with portal war when it comes to parsing and converting units in alert defs (and maybe other areas).

For example, currently if I want the alert condition on platform:

  SystemLoad > 90%

I must type in "0.9" for the value.

If I add the unit, like "0.9%", I get an exception.

If I type "90" it gets converted to 9000%.


Hopefully we can pirate some existing portal war code for all of this...
Comment 1 Charles Crouch 2011-08-12 12:34:38 EDT

*** This bug has been marked as a duplicate of bug 698600 ***

Note You need to log in before you can comment on or make changes to this bug.