Bug 668620 - umlgraph does not show arrows in directed graphs
Summary: umlgraph does not show arrows in directed graphs
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: umlgraph
Version: 14
Hardware: All
OS: All
low
medium
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-10 22:31 UTC by Jorrit
Modified: 2011-01-25 11:42 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-01-25 11:42:08 UTC


Attachments (Terms of Use)
example umlgraph source file that shows the issue (1.56 KB, application/octet-stream)
2011-01-10 22:31 UTC, Jorrit
no flags Details

Description Jorrit 2011-01-10 22:31:40 UTC
Created attachment 472702 [details]
example umlgraph source file that shows the issue

Description of problem:
Graphs created using umlgraph do not show arrow heads and tails.
I can correct this by adding dir=both to this line:

c3:p -> c4:p [taillabel="1..*", label="", headlabel="*", fontname="Helvetica", fontcolor="black", fontsize=10.0, color="black", arrowhead=none, arrowtail=ediamond];

so it looks like:

c3:p -> c4:p [dir=both, taillabel="1..*", label="", headlabel="*", fontname="Helvetica", fontcolor="black", fontsize=10.0, color="black", arrowhead=none, arrowtail=ediamond];

If I however compile an image using graphviz-2.12 which I still have on CentOS the graph looks ok without modifications.

In both cases, the command I use is:
dot -Tpng -o graph.png graph.dot

Version-Release number of selected component (if applicable):
5.2-3

How reproducible:
always

Steps to Reproduce:
1. 
javadoc -docletpath /usr/share/java/umlgraph.jar -doclet org.umlgraph.doclet.UmlGraph -private hazardmap.java
2.
dot -Tpng -o hazardmap.png graph.dot
3.
see output

Actual results:
no arrows in diagram

Expected results:
arrows expected

Additional info:
In communication with graphviz and umlgraph authors I found out this was due to a change in graphviz requiring the direction to be stated.
A just released version of umlgraph (5.4) fixes this issue, which I can confirm.
http://www.umlgraph.org/download.html

Comment 1 Alexander Kurtakov 2011-01-11 07:15:23 UTC
Are you Fedora packager already? Do you want to be co-maintainer and help me with this package maintenance?

Comment 2 Fedora Update System 2011-01-11 08:01:34 UTC
umlgraph-5.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/umlgraph-5.4-1.fc14

Comment 3 Jorrit 2011-01-11 19:00:06 UTC
(In reply to comment #1)
> Are you Fedora packager already? Do you want to be co-maintainer and help me
> with this package maintenance?

I have my experience with packaging, however the time to be a package maintainer is lacking. Maybe when my calendar is less full.

Comment 4 Jorrit 2011-01-11 19:15:36 UTC
(In reply to comment #2)
> umlgraph-5.4-1.fc14 has been submitted as an update for Fedora 14.
> https://admin.fedoraproject.org/updates/umlgraph-5.4-1.fc14

Works as expected.

thanks!

Comment 5 Fedora Update System 2011-01-19 21:02:42 UTC
umlgraph-5.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Alexander Kurtakov 2011-01-25 11:42:08 UTC
Closing


Note You need to log in before you can comment on or make changes to this bug.