Bug 66877 - ZapfDingbats not working
Summary: ZapfDingbats not working
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-17 21:52 UTC by chris
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-04 14:39:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Short LaTeX file using ZapfDingbats characters (119 bytes, text/plain)
2002-06-20 15:00 UTC, chris
no flags Details
DVI generated from dingsample.ltx (268 bytes, text/plain)
2002-06-20 15:01 UTC, chris
no flags Details

Description chris 2002-06-17 21:52:49 UTC
I've just generated a document using latex which has \usepackage{pifont} at the
top, and then uses the \ding{nnn} command to generate characters from the
ZapfDingbats font.

The same document used to work fine under RedHat 7.2, but has now stopped
working - xdvi displaying the generated DVI file displays Courier (I think)
instead of the expected ZapfDingbats characters.

pdflatex on the same file generates a PDF with the correct fonts, though.

Comment 1 Tim Waugh 2002-06-20 10:23:01 UTC
Please attach an example file.  Thanks.

Comment 2 chris 2002-06-20 14:58:46 UTC
OK - I'll attach a short sample LaTeX source and the generated DVI file.

According to the psnfss docs, it should display as 4 different pairs of
scissors.  Having run latex on it on my machine, xdvi displays it as the
following four characters:  ! " # $

Thanks.

Comment 3 chris 2002-06-20 15:00:23 UTC
Created attachment 61844 [details]
Short LaTeX file using ZapfDingbats characters

Comment 4 chris 2002-06-20 15:01:52 UTC
Created attachment 61845 [details]
DVI generated from dingsample.ltx

Comment 5 Tim Waugh 2002-06-20 15:08:28 UTC
The DVI file is fine---dvips converts it to a PS file containing scissors.  
Some xdvi problem.

Comment 6 chris 2002-06-21 15:12:43 UTC
Not on this machine, I'm afraid.  dvips converts it to a PS file containing
exactly the same four Courier characters (! " # $).

Comment 7 Tim Waugh 2002-06-21 15:27:43 UTC
_That_ I can't reproduce.  Even your attached DVI converts to working PS for 
me.

Comment 8 chris 2002-07-04 14:39:09 UTC
OK, problem solved - nothing to do with tetex specifically. ZapfDingbats is
missing from the urw-fonts package (there's an entry for d050000l.pfb in
/usr/share/fonts/default/Type1/fonts.dir, but the corresponding d050000l.* files
don't exist).  That's why ghostscript was substituting Courier instead.  Copying
those files from the urw-fonts distributed with RH 7.2 solves that problem.

For some reason I don't quite understand it also seems to have solved the xdvi
problem (after clearing out /var/lib/texmf and re-running xdvi).

I'll file a bug against urw-fonts.

Thanks.

Comment 9 Tim Waugh 2002-07-04 15:59:19 UTC
Okay.


Note You need to log in before you can comment on or make changes to this bug.