Bug 66878 - Build of glibc does not stop on errors
Build of glibc does not stop on errors
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-17 18:15 EDT by Steve Snyder
Modified: 2016-11-24 10:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-17 18:15:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2002-06-17 18:15:29 EDT
Description of Problem:

The most recent version(s) of the glibc SRPMS does a "make check" (self test of
the generated libraries) in the course of building the binary RPMs.  When errors
occure in the self-test, the build continues anyway, generating binary RPMs that
are now known to contain errors.

Version-Release number of selected component (if applicable):

glibc-2.2.5-34.src.rpm

How Reproducible:

Always

Steps to Reproduce:
1. rpm -bb --target i586-redhat-linux /usr/src/redhat/SPECS/glibc.spec

Actual Results:

Testing EUC-CN
Testing GBK
Testing EUC-TW
This might take a while
Testing GB18030 *** FAILED ***
make[2]: ***
[/usr/src/redhat/BUILD/glibc-2.2.5/build-i586-linux/iconvdata/tst-tables.out]
Error 1
make[2]: Target `tests' not remade because of errors.
make[2]: Leaving directory `/usr/src/redhat/BUILD/glibc-2.2.5/iconvdata'
make[1]: *** [iconvdata/tests] Error 2
make -s -C locale tests
make[2]: Entering directory `/usr/src/redhat/BUILD/glibc-2.2.5/locale'
make[2]: Leaving directory `/usr/src/redhat/BUILD/glibc-2.2.5/locale'
make -s -C localedata tests

Expected Results:

Self-test failure should stop the build process, or at least provide some
indication that those shiny-new binary RPM are known to contain failing code.

Additional Information:

Once the build of the binary RPM is completed there is no way to know that
errors have been encountered in the course of the self test(s).  The only way
you would know there are problem is if you were watching the screen when the
failures occurred.
Comment 1 Jakub Jelinek 2002-07-11 05:38:44 EDT
That's because some glibc (and especially gcc) tests are known to fail,
the rpm -ba -v output is checked against output from older glibc/gcc versions
to search for regressions.

Note You need to log in before you can comment on or make changes to this bug.