Bug 668818 - nginx needs eventfd support in kernel
Summary: nginx needs eventfd support in kernel
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nginx
Version: el5
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Jeremy Hinegardner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-11 17:34 UTC by Edouard Bourguignon
Modified: 2013-01-24 11:36 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-05-13 23:59:07 UTC


Attachments (Terms of Use)

Description Edouard Bourguignon 2011-01-11 17:34:40 UTC
Description of problem:
I've just installed nginx on a redhat 5 runing kernel 2.6.18-164.15.1.el5 which seems to lack some feature for nginx. Despite the fact that nginx process starts correctly, there are some errors in the log:

2011/01/11 17:54:47 [emerg] 13033#0: eventfd() failed (38: Function not implemented)
2011/01/11 17:54:47 [alert] 13032#0: worker process 13033 exited with fatal code 2 and can not be respawn

From recent kernel changelog, aio feature which provides eventfd support is implemented since kernel >= 2.6.18-181

Version-Release number of selected component (if applicable):
nginx-0.8.53-1.el5

How reproducible:
static

Steps to Reproduce:
1. run old kernel
2. install nginx
3. start nginx
  
Actual results:
No error when service nginx is started, but can't get a response from nginx. Browser has to wait for a tcp timeout.
Errors in the log:
2011/01/11 17:58:42 [emerg] 13075#0: eventfd() failed (38: Function not implemented)
2011/01/11 17:58:42 [alert] 13074#0: worker process 13075 exited with fatal code 2 and can not be respawn


Expected results:
Nginx should require a minial kernel version since it can't work on any kernel. 

Additional info:
Add Requires: kernel >= 2.6.18-181 in the spec file.
thank you ;)

With kernel 2.6.18-194.17.1 nginx works fine.

Comment 1 Fedora Update System 2011-04-28 03:20:08 UTC
nginx-0.8.54-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/nginx-0.8.54-1.el5

Comment 2 Fedora Update System 2011-04-28 03:20:15 UTC
nginx-0.8.54-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nginx-0.8.54-1.el6

Comment 3 Fedora Update System 2011-04-28 19:56:57 UTC
Package nginx-0.8.54-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing nginx-0.8.54-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/nginx-0.8.54-1.el5
then log in and leave karma (feedback).

Comment 4 junhao82 2011-05-12 07:41:49 UTC
spec file did not require kernel >= 2.6.18-181

Comment 5 Jeremy Hinegardner 2011-05-12 14:21:17 UTC
What did you do that showed that nginx-0.8.54-1.el5 did not require kernel => 2.6.18?  

jjh@thulsadoom:/tmp % curl --silent  -O http://kojipkgs.fedoraproject.org/packages/nginx/0.8.54/1.el5/x86_64/nginx-0.8.54-1.el5.x86_64.rpm
jjh@thulsadoom:/tmp % rpm -qp --requires nginx-0.8.54-1.el5.x86_64.rpm | grep kernel
kernel >= 2.6.18-181

Comment 6 junhao82 2011-05-12 15:28:57 UTC
Apologies, my mistake. Did a yumdownload --source from my build system, which somehow pulled the 0.8.53-1 version. Sorry about that.

Comment 7 Fedora Update System 2011-05-13 23:59:03 UTC
nginx-0.8.54-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-05-14 00:01:03 UTC
nginx-0.8.54-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 kaiwang.chen 2013-01-24 11:36:21 UTC
It's nginx-0.8.55-2.el5, already requires higher kernel version than 2.6.18-128, 
# rpm -q --requires nginx |grep kernel
kernel >= 2.6.18-181

however, when nginx is installed, it does not require kernel upgrade?


Note You need to log in before you can comment on or make changes to this bug.