Bug 668830 - NetworkManager adds hostname to /etc/hosts pointing to localhost
Summary: NetworkManager adds hostname to /etc/hosts pointing to localhost
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager
Version: 6.0
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Dan Williams
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-11 18:14 UTC by Colin.Simpson
Modified: 2018-11-14 11:55 UTC (History)
5 users (show)

Fixed In Version: NetworkManager-0.8.1-7.el6
Doc Type: Bug Fix
Doc Text:
NetworkManager used to update /etc/hosts file, which could cause problems in some configurations. This is now fixed and NetworkManager does not modify /etc/hosts, leaving it for the administrator to set up.
Clone Of:
Environment:
Last Closed: 2011-05-19 14:25:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 740800 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Product Errata RHBA-2011:0769 0 normal SHIPPED_LIVE NetworkManager bug fix and enhancement update 2011-05-18 18:08:36 UTC

Internal Links: 740800

Description Colin.Simpson 2011-01-11 18:14:04 UTC
Description of problem:

IPA does not completely support IPv6, and if using NetworkManager the FQDN is
added to /etc/hosts for both IPv4 & 6, pointing to localhost.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. service NetworkManager start
2.
3.
  
Actual results:

In /etc/hosts
127.0.0.1  rh6client.example.com  f13client  localhost.localdomain  localhost
::1  rh6client.example.com  f13client  localhost6.localdomain  localhost6

Expected results:
127.0.0.1  localhost.localdomain  localhost
::1  localhost6.localdomain  localhost6

Additional info:

Copied from F14 bug as this same bug occurs in RHEL 6.

https://bugzilla.redhat.com/show_bug.cgi?id=648725

also

https://bugzilla.redhat.com/show_bug.cgi?id=635440


This breaks Kerberos/GSSAPI apps.


Expected results:


Additional info:

Comment 8 Misha H. Ali 2011-04-20 08:25:29 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
NetworkManager would insert warning messages in the location /var/log/messages due to the hostname operation. This is now fixed to ensure no unnecessary warnings display during the hostname operation.

Comment 9 Jirka Klimes 2011-04-20 08:41:43 UTC
This note is not exact. I suggest a correction.

Comment 10 Jirka Klimes 2011-04-20 08:43:16 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-NetworkManager would insert warning messages in the location /var/log/messages due to the hostname operation. This is now fixed to ensure no unnecessary warnings display during the hostname operation.+NetworkManager used to update /etc/hosts file, which could cause problems in some configurations. This is now fixed and NetworkManager doesn't touch /etc/hosts, leaving it for the administrator to set it up properly.

Comment 11 Misha H. Ali 2011-04-20 08:54:30 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-NetworkManager used to update /etc/hosts file, which could cause problems in some configurations. This is now fixed and NetworkManager doesn't touch /etc/hosts, leaving it for the administrator to set it up properly.+NetworkManager used to update /etc/hosts file, which could cause problems in some configurations. This is now fixed and NetworkManager does not modify /etc/hosts, leaving it for the administrator to set up.

Comment 12 Misha H. Ali 2011-04-20 08:55:21 UTC
Thanks for technical corrections, Jirka. I've made some minor changes to your edits.

Comment 13 errata-xmlrpc 2011-05-19 14:25:09 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0769.html


Note You need to log in before you can comment on or make changes to this bug.