Bug 668855 - lu_modules_load: assertion failed (module != NULL)
Summary: lu_modules_load: assertion failed (module != NULL)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libuser
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-11 19:50 UTC by John Reiser
Modified: 2011-01-14 14:58 UTC (History)
7 users (show)

Fixed In Version: libuser-0.57.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-14 14:58:17 UTC
Type: ---


Attachments (Terms of Use)
/tmp/anaconda.log (13.00 KB, text/plain)
2011-01-11 19:50 UTC, John Reiser
no flags Details
/tmp/syslog (88.45 KB, text/plain)
2011-01-11 19:50 UTC, John Reiser
no flags Details
output from /sbin/lsmod (2.18 KB, text/plain)
2011-01-11 19:51 UTC, John Reiser
no flags Details
strace.out.gz (about 1MB) (919.58 KB, application/x-gzip)
2011-01-12 20:51 UTC, John Reiser
no flags Details
strace.out.gz (about 1MB) (897.39 KB, application/x-gzip)
2011-01-13 18:17 UTC, John Reiser
no flags Details

Description John Reiser 2011-01-11 19:50:02 UTC
Created attachment 472880 [details]
/tmp/anaconda.log

Description of problem:


Version-Release number of selected component (if applicable):
anaconda-15.14

How reproducible: every time


Steps to Reproduce:
1. Compose install DVD for x86_64 from Fedora 15 rawhide of 2011-01-11, using pungi+lorax.
2. Boot DVD for Install.
3. Accept defaults (Basic storage devices), try to Next from timezone dialog.
  
Actual results: installation aborts with message on VT1:
ERROR:lib/modules.c:214:lu_modules_load:assertion failed: (module != NULL)


Expected results: successful install


Additional info:

Comment 1 John Reiser 2011-01-11 19:50:47 UTC
Created attachment 472881 [details]
/tmp/syslog

Comment 2 John Reiser 2011-01-11 19:51:43 UTC
Created attachment 472883 [details]
output from /sbin/lsmod

Comment 3 John Reiser 2011-01-12 20:51:17 UTC
Created attachment 473130 [details]
strace.out.gz  (about 1MB)

strace output from attaching to anaconda process as soon as VT2 is available at appearance of first graphical dialog:
   strace -p 714 -f -o "|gzip -c >/tmp/strace.out.gz" &

Looking at all the ENOENT errors might be interesting: are some files missing inadvertently?

Comment 4 Jon Masters 2011-01-13 09:08:07 UTC
Haven't looked into this much, but seems to be an Anaconda bug. Why is it assigned to me, out of interest?

Jon.

Comment 5 Chris Lumens 2011-01-13 14:34:05 UTC
Because at first glance, it sounded module related to me.

Anyway, looks like lorax simply isn't including some file that the buildinstall procedure was.

Comment 6 John Reiser 2011-01-13 14:44:53 UTC
If it turns out that lorax forgot something, then that should be fixed.  After that, send this bug _back_ to anaconda because it's a Usability error.  If a file is missing then the message should say "Missing file" and give the name of the file, or at least its *specific* characterization.  Error messages should give enough info to fix the underlying condition, not just say, "Bang! You're dead."

Comment 7 John Reiser 2011-01-13 18:17:34 UTC
Created attachment 473383 [details]
strace.out.gz  (about 1MB)

Same error occurs when DVD is built by pungi+buildinstall.  Here's the strace of anaconda.

Comment 8 John Reiser 2011-01-13 18:19:06 UTC
Changing Component back to anaconda.

Comment 9 Chris Lumens 2011-01-13 18:31:30 UTC
There's no way we can possibly raise a "missing file" dialog - this is some module (who knows what) attempting to be loaded by some program (again, who knows what) that is being used by anaconda very indirectly.  In short, we don't know what file's missing and we aren't even responsible for loading it.  It's not just a simple matter of slapping some dialogs around like you seem to think it is.

Comment 10 Martin Gracik 2011-01-14 08:27:40 UTC
So, I tried installing a compose made with buildinstall and this happens there too. So something must have changed a while ago, because it was working just fine before, and our buildinstall/lorax scripts were not updated to that change.

Comment 11 Martin Gracik 2011-01-14 09:12:02 UTC
Ok, so I tried narrowing down, when this happened. The compose from Jan 11th works, and the compose from Jan 12th doesn't. I also found out that the lu_modules_load function is a libuser function.

So Miroslav, could you help me identify what that libuser wants from us?

Comment 12 Martin Gracik 2011-01-14 09:13:47 UTC
One note, this happens, when we're trying to show the Set root password page, so that points to libuser too.

Comment 13 Martin Gracik 2011-01-14 09:16:43 UTC
If we don't have the libuser.mo in locales, can this cause this assertion fail?

Comment 14 Ales Kozumplik 2011-01-14 10:49:35 UTC
Hitting this too with both buildinstall and lorax. This sucks.

Comment 15 Miloslav Trmač 2011-01-14 13:28:09 UTC
From a first look, this is likely to be a bug in libuser.

A possible temporary workaround is to create /mnt/sysimage/etc/shadow before initializing libuser (.i.e. switching to the "change password" page): this should fix this particular problem, but if anaconda assumes that libuser doesn't manage etc shadow, it can also cause other problems.

Comment 16 Miloslav Trmač 2011-01-14 14:58:17 UTC
Should be fixed in libuser-0.57.1-1.fc15 .


Note You need to log in before you can comment on or make changes to this bug.