Bug 668950 - add Editor Extension for posix group
Summary: add Editor Extension for posix group
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: UI - General UI
Version: 1.2.7
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Viktor Ashirov
URL:
Whiteboard:
: 567888 (view as bug list)
Depends On:
Blocks: 434915
TreeView+ depends on / blocked
 
Reported: 2011-01-12 08:07 UTC by Carsten Grzemba
Modified: 2015-12-07 16:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-07 16:38:41 UTC


Attachments (Terms of Use)
java source for the extension (16.89 KB, application/octet-stream)
2011-01-12 08:07 UTC, Carsten Grzemba
no flags Details
java source for the extension (15.66 KB, application/octet-stream)
2011-01-12 08:08 UTC, Carsten Grzemba
no flags Details
Patch for Editor properties (434 bytes, patch)
2011-01-12 08:13 UTC, Carsten Grzemba
no flags Details | Diff
Console Framework Diffs (1.26 KB, patch)
2011-02-07 23:52 UTC, Nathan Kinder
nkinder: review?
rmeggins: review+
Details | Diff
New Console File (ResEditorPosixGroup.java) (16.54 KB, text/plain)
2011-02-07 23:54 UTC, Nathan Kinder
nkinder: review?
rmeggins: review+
Details
New Console File (ResEditorPosixGpMembers.java) (14.04 KB, text/plain)
2011-02-07 23:54 UTC, Nathan Kinder
nkinder: review?
rmeggins: review+
Details
admin-console patch (2.00 KB, patch)
2011-02-07 23:57 UTC, Nathan Kinder
nkinder: review?
rmeggins: review+
Details | Diff
adminserver patch (2.11 KB, patch)
2011-02-08 00:02 UTC, Nathan Kinder
nkinder: review?
rmeggins: review+
Details | Diff
Posix Group.png (9.79 KB, image/png)
2011-05-12 10:45 UTC, Amita Sharma
no flags Details

Description Carsten Grzemba 2011-01-12 08:07:51 UTC
Created attachment 472962 [details]
java source for the extension

Description of problem:
The attached source files deliver a Console Editor Extension for management of posix group attributes.
For integrating this in the idm-console-framwork copy the files in directory:
src/com/netscape/management/client/ug
and extent the resource strings in the PickerEditorResource.properties

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Carsten Grzemba 2011-01-12 08:08:59 UTC
Created attachment 472963 [details]
java source for the extension

Comment 2 Carsten Grzemba 2011-01-12 08:13:10 UTC
Created attachment 472964 [details]
Patch for Editor properties

Comment 3 Carsten Grzemba 2011-01-12 08:18:14 UTC
For adding this extension there must add this in the LDAP configuration:

dn: cn=groupofuniquenames,cn=ResourceEditorExtension,ou=1.1,ou=Admin,ou=Global
  Preferences,ou=<organization>,o=NetscapeRoot
changetype: replace
add: nsclassname
nsclassname: com.netscape.management.client.ug.ResEditorPosixGroup

Can somebody add this to the inital configuration? I do not know where to do this entry.

Comment 4 Nathan Kinder 2011-02-07 23:52:43 UTC
Created attachment 477527 [details]
Console Framework Diffs

Comment 5 Nathan Kinder 2011-02-07 23:54:04 UTC
Created attachment 477528 [details]
New Console File (ResEditorPosixGroup.java)

Comment 6 Nathan Kinder 2011-02-07 23:54:47 UTC
Created attachment 477529 [details]
New Console File (ResEditorPosixGpMembers.java)

Comment 7 Nathan Kinder 2011-02-07 23:57:25 UTC
Created attachment 477530 [details]
admin-console patch

Comment 8 Nathan Kinder 2011-02-08 00:02:05 UTC
Created attachment 477531 [details]
adminserver patch

Comment 9 Nathan Kinder 2011-02-08 17:00:42 UTC
Pushed all patches to master/HEAD.  Thanks to Rich for his review!

Counting objects: 12, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (6/6), done.
Writing objects: 100% (7/7), 1.00 KiB, done.
Total 7 (delta 3), reused 0 (delta 0)
To ssh://git.fedorahosted.org/git/389/admin-console.git
   42c10a6..4ffc63b  master -> master

Counting objects: 11, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (5/5), done.
Writing objects: 100% (6/6), 630 bytes, done.
Total 6 (delta 4), reused 0 (delta 0)
To ssh://git.fedorahosted.org/git/389/admin.git
   4aecc23..1392e7d  master -> master

Checking in src/com/netscape/management/client/ug/PickerEditorResource.properties;
/cvs/dirsec/console/src/com/netscape/management/client/ug/PickerEditorResource.properties,v  <--  PickerEditorResource.properties
new revision: 1.5; previous revision: 1.4
done
RCS file: /cvs/dirsec/console/src/com/netscape/management/client/ug/ResEditorPosixGpMembers.java,v
done
Checking in src/com/netscape/management/client/ug/ResEditorPosixGpMembers.java;
/cvs/dirsec/console/src/com/netscape/management/client/ug/ResEditorPosixGpMembers.java,v  <--  ResEditorPosixGpMembers.java
initial revision: 1.1
done
RCS file: /cvs/dirsec/console/src/com/netscape/management/client/ug/ResEditorPosixGroup.java,v
done
Checking in src/com/netscape/management/client/ug/ResEditorPosixGroup.java;
/cvs/dirsec/console/src/com/netscape/management/client/ug/ResEditorPosixGroup.java,v  <--  ResEditorPosixGroup.java
initial revision: 1.1
done

Comment 10 Amita Sharma 2011-05-12 10:45:22 UTC
Created attachment 498500 [details]
Posix Group.png

Posix Group.png

Comment 11 Amita Sharma 2011-05-12 10:47:02 UTC
I got this entry by ldapsearch :

# groupofuniquenames, ResourceEditorExtension, 1.1, Admin, Global Preferences
 , corp.example.com, NetscapeRoot
dn: cn=groupofuniquenames,cn=ResourceEditorExtension,ou=1.1,ou=Admin,ou=Global
  Preferences,ou=corp.example.com,o=NetscapeRoot
objectClass: nsResourceRef
objectClass: nsAdminResourceEditorExtension
objectClass: top
objectClass: extensibleObject
objectClass: nsAdminObject
nsmerge: {nsclassname}MULTI_MERGE
nsClassname: com.netscape.management.client.ug.ResEditorGroupInfo
nsClassname: com.netscape.management.client.ug.ResEditorGroupMembers
nsClassname: com.netscape.management.client.ug.ResEditorAccountPage
nsClassname: com.netscape.management.client.ug.LanguagePage
nsClassname: com.netscape.management.client.ug.ResEditorPosixGroup
cn: groupofuniquenames


So, I guess I don't need to install anything for Console Editor Extension for management of posix group attributes?

And by looking at code attached, there is mentioned "IResourceEditorPage interfac"GIDNumbe and MEMBERUI, If I am not wrong then this is the one I have attached here with(Posix Group.png). Please confirm.

Thanks,
Amita

Comment 12 Jenny Severance 2011-05-16 17:33:32 UTC
Are comments 10 and 11 enough for bug verification?   Thanks

Comment 13 Nathan Kinder 2011-05-17 15:37:24 UTC
Comment(In reply to comment #12)
> Are comments 10 and 11 enough for bug verification?   Thanks

Comment 10 (along with adding a new posixGroup through the UI) should be sufficient for verification.  The Console tests will need to test this new UI as well.

Comment 14 Amita Sharma 2011-05-18 10:47:36 UTC
ok, thanks Nathan.. I am marking this bug as VERIFIED.

Comment 15 Rich Megginson 2012-03-30 16:23:50 UTC
*** Bug 567888 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.