Bug 669016 - Anaconda reports "Network error" despite DHCP being successfully configured
Anaconda reports "Network error" despite DHCP being successfully configured
Status: CLOSED DUPLICATE of bug 669019
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 669017 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-12 08:18 EST by Elie Bleton
Modified: 2011-01-13 10:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 10:11:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Elie Bleton 2011-01-12 08:18:29 EST
Description of problem:

During an automated text-mode anaconda installation (configured with a kickstart file), anaconda fails with the following error message :

" | Network Error |
There was an error configuring your network interface. "

At this point, the target computer have been configured with DHCP and can be pinged. 
Hitting "Retry" will destroy the networking configuration, rendering the machine unpingable.


However, the shell on pty/2 is not available, and sshd is not started (having given sshd in pxelinux append= parameter, and set "sshpw" entries in kickstart).


Version-Release number of selected component (if applicable):
Default anaconda with F14


How reproducible:
Transient error / happens about half the time on our setup (DHCP via dhcrelay).
PXE boot, which uses same DHCP server, works 100% of the time.


Steps to Reproduce:
1. (may or may not be relevant) Have subnets 10.0.0.0/24 and 10.0.1.0/24, dhcpd on 10.0.1.1, routing box sitting on both 10.0.0.1 and 10.0.1.254 with dhcrelay
2. use cobbler to pxe boot into anaconda
3. watch failure, or retry until it happens
  
Actual results:

Network fails about half the time, otherwise installs just fine

Expected results:

Installation proceeds everytime

Additional info:
Comment 1 Chris Lumens 2011-01-13 09:26:16 EST
*** Bug 669017 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2011-01-13 09:27:17 EST
If you pass the "debug" parameter, you can hit ^Z during installation and be dropped to a shell.  From there, you won't have much available but you should have scp.  Can you use that to grab the logs and then attach them to this bug?
Comment 3 Radek Vykydal 2011-01-13 10:11:46 EST

*** This bug has been marked as a duplicate of bug 669019 ***

Note You need to log in before you can comment on or make changes to this bug.