Bug 669037 - [abrt] gnome-settings-daemon-2.91.8-1.fc15: Process /usr/libexec/gnome-settings-daemon was killed by signal 11 (SIGSEGV)
Summary: [abrt] gnome-settings-daemon-2.91.8-1.fc15: Process /usr/libexec/gnome-settin...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: rawhide
Hardware: x86_64
OS: Unspecified
low
high
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c5e2d4ba688b9020d4253bf7f5b...
Keywords:
Depends On:
Blocks: F15Blocker, F15FinalBlocker F15Alpha-accepted, F15AlphaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-01-12 14:32 UTC by Matěj Cepl
Modified: 2018-04-11 11:54 UTC (History)
21 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-02-18 12:35:45 UTC


Attachments (Terms of Use)
File: backtrace (21.43 KB, text/plain)
2011-01-12 14:32 UTC, Matěj Cepl
no flags Details

Description Matěj Cepl 2011-01-12 14:32:40 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/gnome-settings-daemon
comment: Result was a black screen with mouse, but nothing working. When I run xterm on other console with export DISPLAY=:0 it was blinking every other second.
component: gnome-settings-daemon
executable: /usr/libexec/gnome-settings-daemon
kernel: 2.6.37-2.fc15.x86_64
package: gnome-settings-daemon-2.91.8-1.fc15
reason: Process /usr/libexec/gnome-settings-daemon was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1294842074
uid: 500

How to reproduce
-----
1.starting gnome session from gdm
2.
3.

Comment 1 Matěj Cepl 2011-01-12 14:32:43 UTC
Created attachment 473037 [details]
File: backtrace

Comment 2 Matěj Cepl 2011-01-12 14:37:36 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.no gnome=shell
2.
3.

Comment 3 Sam K. Raju 2011-01-13 07:14:34 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.Just connect the USB drive to the system. It crashes
2.
3.

Comment 4 ritz 2011-01-13 12:56:11 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. nfc
2.
3.


Comment
-----
dual screen setup

lvds1 and dvi1

Comment 5 Raphos 2011-01-14 14:40:49 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.Start Firefox
2.
3.

Comment 6 Matěj Cepl 2011-01-16 15:07:14 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.no idea, just running gnome-shell and observing loose of settings
2.
3.

Comment 7 Stephen 2011-01-16 17:39:44 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Attempted to logon into Gnome ?
2.
3.

Comment 8 A S Alam 2011-01-17 12:06:05 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.inserted USB drive and got crash
2.
3.

Comment 9 Raphos 2011-01-19 20:49:48 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.Start Nautilus
2.
3.

Comment 10 Raphos 2011-01-19 21:44:09 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.Shutdown computer
2.
3.

Comment 11 Raphos 2011-01-20 11:35:24 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.Plug a usb stick
2.
3.

Comment 12 Wolfgang Ulbrich 2011-01-22 19:41:53 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. nothing
2.
3.

Comment 13 Horst H. von Brand 2011-01-22 22:20:50 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Start shut down; unplug USB mouse, keyboard; unplug monitor; unplug eth0
2.
3.


Comment
-----
The above is my best guess given the time of the crash. I closed firefox, xemacs before.

Comment 14 Horst H. von Brand 2011-01-22 22:23:41 UTC
(In reply to comment #13)
> Package: gnome-settings-daemon-2.91.8-1.fc15
> Architecture: x86_64
> OS Release: Fedora release 15 (Rawhide)
> 
> 
> How to reproduce
> -----
> 1. Start shut down; unplug USB mouse, keyboard; unplug monitor; unplug eth0
> 2.
> 3.
> 
> 
> Comment
> -----
> The above is my best guess given the time of the crash. I closed firefox,
> xemacs before.

I am running gnome-shell-2.91.5-3.fc15.x86_64

Comment 15 Horst H. von Brand 2011-01-24 01:25:03 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Inserted an SD card
2.
3.

Comment 16 Horst H. von Brand 2011-01-24 01:28:42 UTC
(In reply to comment #15)
> Package: gnome-settings-daemon-2.91.8-1.fc15
> Architecture: x86_64
> OS Release: Fedora release 15 (Rawhide)
> 
> 
> How to reproduce
> -----
> 1. Inserted an SD card

SD card wasn't formatted, BTW.

Comment 17 Adam Williamson 2011-01-24 07:24:38 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Crash happened while I was using abrt-gui to report a previous gnome-settings-daemon crash!
2.
3.

Comment 18 Adam Williamson 2011-01-24 07:25:23 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Plugged in a removable drive, it auto-mounted, g-s-d crashed
2. Running current Rawhide with GNOME 3
3.

Comment 19 Adam Williamson 2011-01-24 07:27:14 UTC
proposing for F15 final blocker and Alpha NTH list - this is a polish/stability issue, really shouldn't have a core GNOME component crashing all over the place.

Comment 20 Jared Smith 2011-01-24 09:07:56 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Trying out control center in Gnome Shell
2.
3.

Comment 21 Jared Smith 2011-01-24 09:10:36 UTC
(In reply to comment #19)
> proposing for F15 final blocker and Alpha NTH list - this is a polish/stability
> issue, really shouldn't have a core GNOME component crashing all over the
> place.

I agree that this should probably be on the F15 blocker list.

Comment 22 Luya Tshimbalanga 2011-01-24 20:42:47 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Log in to Gnome 3
2.
3.


Comment
-----
Not sure how that happens. Probably by log in on desktop.

Comment 23 Jared Smith 2011-01-25 04:54:06 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Logged in as a user w/ Gnome shell
2. Connected to network via NetworkManager
3. Watched things crash...

Comment 24 Jared Smith 2011-01-25 04:57:34 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Plugged in a USB key
2. Watched things crash :-(
3.

Comment 25 cornel panceac 2011-01-29 09:46:31 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.
2.
3.
i don\t know if it can be repouced

Comment 26 Kenny Strawn 2011-01-30 16:55:45 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. This crash reported itself, without my interaction. As such, I don't know the steps to reproduce it.
2.
3.

Comment 27 Kenny Strawn 2011-01-30 16:57:12 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. This crash reported itself. As such, I don't know the steps to reproduce it.
2.
3.

Comment 28 Rahul Sundaram 2011-01-31 21:23:09 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.  unlocked the screensaver
2.
3.

Comment 29 Bonacina Alberto 2011-02-01 22:44:43 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Open Gnome Sound Setting Applet
2. Change the selected device in the hardware tab
3. Test Speaker
4. Crash

Comment 30 Kjartan Maraas 2011-02-03 19:00:18 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Probably happened during suspend to disk or shutdown or something like that?
2.
3.

Comment 31 Jan Svec 2011-02-08 17:38:45 UTC
Package: gnome-settings-daemon-2.91.8-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.i opened pidgin
2.
3.

Comment 32 Matthias Clasen 2011-02-11 19:13:34 UTC
Bastien says that this is probably fixed in the current builds of gnome-settings-daemon and gnome-desktop3. Are people still seeing it ?

Comment 33 Jared Smith 2011-02-11 19:32:33 UTC
I'm no longer seeing this with the latest packages from rawhide.

Comment 34 James Laska 2011-02-11 19:55:31 UTC
Per 2011-02-11 Alpha blocker meeting -

  * AGREED: 669037 - Accepted as Alpha NICE-TO-HAVE (F15Alpha-accepted)
  * potentially consider for F15Beta blocker since this *may* impact
    insertion/removal of removable media

http://meetbot.fedoraproject.org/fedora-bugzappers/2011-02-11/f15alpha-bug-review.2011-02-11-17.00.html

Comment 35 Adam Williamson 2011-02-12 06:14:03 UTC
no, haven't seen this lately.

Comment 36 Kjartan Maraas 2011-02-12 11:34:58 UTC
[  138.927922] gnome-settings-[1351]: segfault at 4886e430 ip 4886e430 sp bfeff11c error 14 in libgdk-3.0.so.0.9903.0[488ae000+7e000]

This is from my dmesg this boot cycle. It's been up 2 days though, but I don't recall there being any updates for gnome-settings-daemon in that period.

Comment 37 Bastien Nocera 2011-02-18 12:35:45 UTC
(In reply to comment #36)
> [  138.927922] gnome-settings-[1351]: segfault at 4886e430 ip 4886e430 sp
> bfeff11c error 14 in libgdk-3.0.so.0.9903.0[488ae000+7e000]
> 
> This is from my dmesg this boot cycle. It's been up 2 days though, but I don't
> recall there being any updates for gnome-settings-daemon in that period.

Need a new bug and backtrace for this.

I'll close this as fixed in gnome-desktop3 2.91.6.1-2

Comment 38 Kjartan Maraas 2011-02-18 16:27:38 UTC
I still see the segfault message in dmesg, but gnome-settings-daemon is running in my session when I log in:

[kmaraas@e4300 ~]$ dmesg | grep settings
[  139.612772] gnome-settings-[1342]: segfault at 489532b0 ip 489532b0 sp bfcf59fc error 14 in libgtk-3.so.0.0.0[48993000+42b000]
[kmaraas@e4300 ~]$ rpm -q gnome-desktop3
gnome-desktop3-2.91.6.1-4.fc15.i686
[kmaraas@e4300 ~]$ rpm -q gnome-settings-daemon
gnome-settings-daemon-2.91.9-4.fc15.i686
[kmaraas@e4300 ~]$ uptime
 17:25:51 up 59 min,  2 users,  load average: 0.12, 0.31, 0.23
[kmaraas@e4300 ~]$ ps ax | grep settings
 1532 ?        Sl     0:00 /usr/libexec/gnome-settings-daemon
 1594 ?        Sl     0:00 /usr/libexec/imsettings-daemon
 2630 pts/0    R+     0:00 grep --color=auto settings


Note You need to log in before you can comment on or make changes to this bug.