Bug 669096 - Entitlement beta compose does not include rhsm in minimal install
Summary: Entitlement beta compose does not include rhsm in minimal install
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Dennis Gregorovic
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2011-01-12 16:47 UTC by J.C. Molet
Modified: 2011-02-23 21:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-23 21:51:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description J.C. Molet 2011-01-12 16:47:18 UTC
Description of problem:
When installing the entitlement beta compose located here:

http://download.lab.bos.redhat.com/devel/candidates/RHEL6.1-20110110.4/

It does not include the subscription manager packages when doing the minimal install.

Steps to Reproduce:
1. Install the compose located at the link above
2. Run though the setup steps and select minimal install when asked.
  
Actual results:
python-rhsm and subscription-manager are not installed.

Expected results:
python-rhsm and subscription-manager are installed.

Comment 1 Bryan Kearney 2011-01-20 17:23:18 UTC
latest compose, http://download.devel.redhat.com/devel/candidate-trees/RHEL6.1-20110118.0/, has htis when you select basic server.

Comment 3 spandey 2011-01-21 10:32:58 UTC
Verified using following setup 

Beta build : http://download.devel.redhat.com/devel/candidate-trees/RHEL6.1-20110118.0/

python-rhsm and subscription manager rpm installed in basic server option 

moving defect status from Modified to Verified 

Please reopen this if you feel defect is not fixed

Comment 4 J.C. Molet 2011-01-21 15:09:47 UTC
The "basic server" selection always had these packages.  I'm talking about the "Minimal" selection.

This selection would be located (in the graphical install), in the selection box with the text above: "The default installation of Red Hat Enterprise Linux is a basic server install.  You can optionally select a different set of software now."

The 'minimal' option is under the 'Software Development Workstation' option.

From my minimal install:

[root@jmolet-vm4 ~]# rpm -qa | egrep "subscription|rhn"
rhn-client-tools-1.0.0-41.el6.noarch
rhn-setup-1.0.0-41.el6.noarch
rhn-check-1.0.0-41.el6.noarch
rhnlib-2.5.22-9.el6.noarch
rhnsd-4.9.3-2.el6.x86_64
yum-rhn-plugin-0.9.1-7.el6.noarch

In this beta, shouldn't the subscription manager be included in any package sets that the rhn tools are?

Comment 5 Dennis Gregorovic 2011-01-21 15:27:54 UTC
The issue is that subscription-manager-cli was renamed to subscription-manager, but comps.xml still had the former listed.  I'll get this fixed for the next compose.

Comment 6 J.C. Molet 2011-01-21 20:39:51 UTC
[root@jmolet-vm4 ~]# rpm -qa | grep subscription
subscription-manager-0.93.14-1.el6.x86_64

tested as working as of rhsm compose:  RHEL6.1-20110121.0


Note You need to log in before you can comment on or make changes to this bug.