Bug 66911 - procps-X11 lacks X11 requirement
procps-X11 lacks X11 requirement
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-18 10:24 EDT by Steve Snyder
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-19 10:55:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2002-06-18 10:24:07 EDT
Description of Problem:

The procps-X11-2.0.7-12 package is installed (by RHL v7.3 installer) on a
text-only system.  The reason appears to be that procps-X11 is not built with a
requirement that X11 be present.

Version-Release number of selected component (if applicable):

procps-X11-2.0.7-12

How Reproducible:

Always.

Steps to Reproduce:
1. Install RedHat Linux v7.3 without any XFree86 support 
2. Note that procps-X11-2.0.7-12 is installed 
3. 

Actual Results:

procps-X11-2.0.7-12 is installed

Expected Results:

The proc-X11 package should require XFree86.

Additional Information:
	
# rpm -q --requires procps-X11
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
/bin/sh
Comment 1 Alexander Larsson 2002-07-01 10:15:48 EDT
I'm not sure what to do here. procps-X11 only contains the XConsole shell
script, and all that does it start xconsole, which is in the XFree86 package.
Pretty worthless package.

Since the package is only 213 bytes and a change will need some installer and
upgrade testing i'm inclined to not care, so i'm closing this NOTABUG.

Comment 2 Michael K. Johnson 2002-07-12 09:42:59 EDT
It's not clear to me that there's still any need to ship the procps-X11
package at all in Limbo.  Perhaps we should just remove it; it was there
only for backwards compatibility years ago.

Note You need to log in before you can comment on or make changes to this bug.