Bug 669155 - [abrt] qtcWindowDelayedUpdate was killed by signal 11 (SIGSEGV)
Summary: [abrt] qtcWindowDelayedUpdate was killed by signal 11 (SIGSEGV)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qtcurve-gtk2
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c8b74d5b81eb694313721601f01...
: 669838 689692 712541 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-12 19:13 UTC by luxyrybugs
Modified: 2011-06-13 04:02 UTC (History)
7 users (show)

Fixed In Version: qtcurve-gtk2-1.8.5-4.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-30 20:01:49 UTC


Attachments (Terms of Use)
File: backtrace (35.67 KB, text/plain)
2011-01-12 19:13 UTC, luxyrybugs
no flags Details
make timer callbacks threadsafe (1.17 KB, patch)
2011-01-13 05:48 UTC, David Tardon
no flags Details | Diff

Description luxyrybugs 2011-01-12 19:13:32 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/scalc.bin -calc
component: openoffice.org
crash_function: gdk_window_invalidate_rect_full
executable: /usr/lib/openoffice.org3/program/scalc.bin
kernel: 2.6.35.10-74.fc14.i686.PAE
package: openoffice.org-calc-1:3.3.0-18.2.fc14
rating: 4
reason: Process /usr/lib/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
How to reproduce: 1.Every time i scroll up and down in Calc or Writer
time: 1294856551
uid: 500

Comment 1 luxyrybugs 2011-01-12 19:13:35 UTC
Created attachment 473107 [details]
File: backtrace

Comment 2 Caolan McNamara 2011-01-12 20:28:21 UTC
Not reported before, almost certainly due to your theme which is presumably qtcurve. If you try another one does it "go away"

Comment 3 David Tardon 2011-01-13 05:48:48 UTC
Created attachment 473219 [details]
make timer callbacks threadsafe

Maybe it is a threading issue, seeing that the qtcWWMoveStartDelayedDrag function is invoked by timer, but it calls Gdk/Gtk functions without acquiring the gdk mutex first (see http://library.gnome.org/devel/gdk/stable/gdk-Threads.html). In that case, the attached patch should fix it.

Comment 4 David Tardon 2011-01-15 11:24:18 UTC
*** Bug 669838 has been marked as a duplicate of this bug. ***

Comment 5 David Tardon 2011-03-22 08:13:20 UTC
*** Bug 689692 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Admin XMLRPC Client 2011-03-22 09:39:58 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 7 Fedora Update System 2011-03-22 12:51:54 UTC
qtcurve-gtk2-1.8.5-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qtcurve-gtk2-1.8.5-4.fc14

Comment 8 Fedora Update System 2011-03-22 12:57:34 UTC
qtcurve-gtk2-1.8.5-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qtcurve-gtk2-1.8.5-4.fc15

Comment 9 Fedora Update System 2011-03-30 20:01:43 UTC
qtcurve-gtk2-1.8.5-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-03-31 20:00:24 UTC
qtcurve-gtk2-1.8.5-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 David Tardon 2011-06-13 04:02:48 UTC
*** Bug 712541 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.