Bug 66934 - explicit prefix "/mnt/cdrom" causes problems if iso is mounted elsewhere
Summary: explicit prefix "/mnt/cdrom" causes problems if iso is mounted elsewhere
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: unspecified
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-18 20:22 UTC by Ben Levenson
Modified: 2007-07-31 19:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-06-21 15:22:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ben Levenson 2002-06-18 20:22:11 UTC
Description of Problem:
Traceback occurs if the installer isn't mounted @ /mnt/cdrom:

[root@test81 root]# /mnt/installer/usr/sbin/satinstall
Traceback (innermost last):
  File "/mnt/installer/usr/sbin/satinstall", line 33, in ?
    from satinstall import tnsnames
ImportError: No module named satinstall

from /usr/sbin/satinstall:
<snip>
     30 prefix = "/mnt/cdrom/"
     31 sys.path.append("%s/usr/share/rhn/" % prefix)
     32
     33 from satinstall import tnsnames
     34 from satinstall import satConfig
     35 from satinstall import satInstall
     36 from satinstall import satInstallErrors
<snip>

Steps to Reproduce:
1. mount the iso at anything but /mnt/cdrom
2. try to launch the installer

Additional Information:
should the prefix be dynamic? I don't know python, otherwise I might offer
another suggestion.

Comment 1 Adrian Likins 2002-06-20 18:24:40 UTC
Not really a bug. We are working on the assumption the 
installer is always mounted on /mnt/cdrom.

If that assumption is not correct, we need to change
the spec and the code.

gdk: we are still assuming the cd will be at /mnt/cdrom correct?

Comment 2 Josef Komenda 2002-06-24 14:08:58 UTC
Easy enough to make /mnt/cdrom an explicit requirement, since we're doing a
clean install. Closing.


Note You need to log in before you can comment on or make changes to this bug.