Bug 66937 - NCHardwareList:288:save KeyError: options
NCHardwareList:288:save KeyError: options
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks: rcn-7.3
  Show dependency treegraph
 
Reported: 2002-06-18 16:49 EDT by John Raff
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-26 20:12:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Raff 2002-06-18 16:49:49 EDT
Gnome Run "Network Configuration"

Description of Problem:
On the hardware tab attempted to apply new setting and got a crash dump.

Version-Release number of selected component (if applicable):
RH 7.3 downloaded 6/8/02 installed to a Pentium III 700mhz with 256meg ram.
oodles of HD space.

How Reproducible:
Very, happened each time I tried to "apply" hardware (io and irc) changes.

Steps to Reproduce:
1. start network_configurator under Gnome
2. click on hardware tab
3. select and edit hardware parameters, close and attempt to "apply"

Actual Results:
Crash dump

Expected Results:
properly configured network card

Additional Information:
Crash dump files;

1st time
--------------------
Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/NCHardwareList.py", line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__
[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 8413850>
hw: <netconfpkg.HardwareList.Hardware instance at 83a33f8>
selfkey: IoPort
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 8585e20>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 85f2b98>
confkey: io
self: [<netconfpkg.HardwareList.Hardware instance at 83a33f8>]
-------------
2nd time
--------------
Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 653, in on_deviceActivateButton_clicked
    if self.save() != 0:
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/NCHardwareList.py", line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__
[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 8521ca0>
hw: <netconfpkg.HardwareList.Hardware instance at 84e8db0>
selfkey: IoPort
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 8521780>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 84e65d8>
confkey: io
self: [<netconfpkg.HardwareList.Hardware instance at 84e8db0>]
--------------
3rd time
---------------
Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/NCHardwareList.py", line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__
[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 8504d18>
hw: <netconfpkg.HardwareList.Hardware instance at 84e8db0>
selfkey: IoPort
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 84fb6c8>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 8501290>
confkey: io
self: [<netconfpkg.HardwareList.Hardware instance at 84e8db0>]
Comment 1 Josef Komenda 2002-06-18 17:12:55 EDT
This should have been opened against 7.3, not RHN. Not sure about the package
this applies to.
Comment 2 Harald Hoyer 2002-06-26 12:14:45 EDT
fixed in CVS
Comment 3 paulliluca 2002-06-26 20:12:38 EDT
i don't know if this can help.
A similar problem when i enter Network Configuration has been occurred since I
am running Windows 2000 server. 
if u need to contact me paulliluca@hotmail.com
Comment 4 Trond Eivind Glomsrxd 2002-07-24 12:52:02 EDT
(removing RHN guys from CC)

The fix should be in newer versions of redhat-config-network, like, 1.1 11 -
please verify this with the public beta.
Comment 5 Harald Hoyer 2002-10-23 05:58:32 EDT
first beta of erratum for 7.3/7.2 is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

Note You need to log in before you can comment on or make changes to this bug.