Bug 66943 - (NET EEPRO100) eepro100 lockups on IBM Thinkpad T23
(NET EEPRO100) eepro100 lockups on IBM Thinkpad T23
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-18 17:34 EDT by Peter Fales
Modified: 2013-07-02 22:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Fales 2002-06-18 17:34:09 EDT
Description of Problem:

There are apparently some incompatibilities between the driver and the 
hardware for the eepro100 used on the IBM Thinkpad T23.  There are several
references on the web to "lockups" caused by this hardware/software 
combination (e.g. http://www.alex.org.uk/T23/).  One suggested workaround
is to use the e100 driver instead of the eepro100 driver.  In fact we've done
this using RedHat's e100 driver, and it seems to work fine.  

However, we've also been bitten by this during network intallations (e.g. 
kickstarts) and in addition to making Linux look unstable, it substantially
increases the time needed to do a kickstart.  I looked briefly at alternatives,
but was blocked when I discovered that the e100 driver is not available on the
supplmental driver disk.  

I realize that a driver fix for this is probably not going to be possible.  So,
what I'm really asking is whether the e100 driver could be included as one of
the alternate drivers on the driver disk.



How Reproducible:

Typically happens roughly 2 or 3 times during a network installation of
RedHat 7.3.  Usually recovers on its own, but it can tens of minutes
of no activity before it recovers.


Additional Information:
Comment 1 Jeremy Katz 2002-06-19 22:39:09 EDT
Nope, we've been asked by the kernel team to not place the e100 driver on driver
disks; you're welcome to make your own, though.  

Reassigning to kernel so that the root problem (the fact that the eepro100
driver + the t23 ethernet chip doesn't work so well) can be investigated
Comment 2 John Klingler 2003-09-25 16:29:12 EDT
The problem of eepro100 locking up the OS was also reported by one of our
customers who supplied the following test script:
----------------------------------------------
#!/bin/csh
next:
 x11perf -putimagexy100 >>& log
 x11perf -circulate >>& log
 x11perf -copypixpix500 >>& log
 x11perf -rgbftext >>& log
goto next
----------------------------------------------
This will lock up Red Hat 8.0 in a matter of minutes on a 10Mbps connection.
The OS just stops, no errors, doesn't respond to ping. I verified this.
The customer reported eepro100 also locks up after 24 hours on a 100Mbps
connection. I didn't verify that. 
The workaround is to install e100, which apparently eliminates the problem.
I verified this on 10Mbps Ethernet for several days of testing.
Comment 3 John Klingler 2003-09-25 18:01:43 EDT
I forgot to add that the customer reported that the eepro100 problem only happens
with the on-board i815 chipset. When they installed an Intel Pro/100S adapter, the
problem did not occur. (I was not in a position to confirm this.)

I hope this helps.
Comment 4 Niels Kristian Jensen 2004-05-12 15:54:46 EDT
Today I tried to upgrade a RH9 on a IBM T23 to FC2 test3 (1.92) using
the FTP-method after having booted from the small boot-iso CD.

It hangs if I connect via an old half-duplex 10 MBit/s hub but works
fine if I use a 10/100 Mbit/s full duplex switch. It's very much the
same symptoms as in bug #64714 which ended up in "drop eepro100, use
e100". I guess that the boot.iso program still uses the (buggy)
eepro100 driver?
Comment 5 Peter Fales 2004-05-12 21:25:30 EDT
I'm not sure this is the same problem.  I observed it quite
consistently in RH7.3, and the only way we could get reliable installs
was to replace the eepro100 driver with e100 on the boot disk.  That
fix was not needed on RH8.0 or RH9.  (Haven't tried Fedora on a T23 
yet - I suppose the problem could be back)
Comment 6 Bugzilla owner 2004-09-30 11:39:40 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.