Bug 66951 - XFree86 4.1.0-25 upgrade makes fonts.*.rpmnew files
XFree86 4.1.0-25 upgrade makes fonts.*.rpmnew files
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-18 21:03 EDT by Mike A. Harris
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version: 4.1.0-48
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-14 06:59:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2002-06-18 21:03:55 EDT
Description of Problem:
warning: /usr/X11R6/lib/X11/fonts/latin2/Type1/fonts.alias created as
/usr/X11R6/lib/X11/fonts/latin2/Type1/fonts.alias.rpmnew
warning: /usr/X11R6/lib/X11/fonts/latin2/Type1/fonts.scale created as
/usr/X11R6/lib/X11/fonts/latin2/Type1/fonts.scale.rpmnew

Upgrading to 4.1.0-25 creates rpmnew files.  This problem is solved
in 4.2.0 as shipped with RHL 7.3, and any future 7.1/7.2 erratum of
XFree86 4.1.0 should also fix this problem.
Comment 1 Mike A. Harris 2003-05-14 06:59:26 EDT
This problem doesn't appear to be in the current XFree86.spec for 4.1.0-48,
however if upon upgrading to this release, the problem is still present, then
it is likely the result of the previously installed XFree86 flagging the
above files as %config(noreplace) which is broken.  If this is the case,
it can not be fixed because the bug is in the XFree86 package already installed
on the system, and we can't fix a file which is installed with bad flags.

Users can just blow away the .rpmnew files, or move them on top of the
other files, or even just leave them alone.

Note You need to log in before you can comment on or make changes to this bug.