Bug 66952 - gcc generates incorrect code when using mcpu and march i686
gcc generates incorrect code when using mcpu and march i686
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 814674 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-18 21:49 EDT by Suchandra Thapa
Modified: 2012-06-20 03:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 17:26:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suchandra Thapa 2002-06-18 21:49:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
gcc can't build binary rpms of R 1.5.1 if 686 specific instructions and
scheduling are specified.

Version-Release number of selected component (if applicable): 2.96-98

How reproducible:
Always

Steps to Reproduce:
1. Obtain R-base 1.51 source rpm from
http://cran.r-project.org/bin/linux/redhat/SRPMS/
2. Try building with RPM_OPT_FLAGS  -O2 -mcpu=i686 -march=i686

Actual Results:  Build fails with an segfault in generated binary, build works
RPM_OPT_FLAGS are  -O2 -mcpu=i586 -march=i586.  


Expected Results:  Build should have succeeded.

Additional info:

This was observed on a dual p3 500 system with gcc-2.96-98.
Comment 1 Suchandra Thapa 2002-07-09 18:28:09 EDT
This is also present with the gcc-2.96-100 package which comes with redhat 7.3
Comment 2 Richard Henderson 2004-10-02 17:26:12 EDT
Works with gcc 3.2 and R 1.9.1.
Comment 3 Stanislaw Gruszka 2012-06-20 03:07:03 EDT
*** Bug 814674 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.