Bug 66954 - Windows key is not a recognized modifier for keyboard shortcuts
Windows key is not a recognized modifier for keyboard shortcuts
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: control-center (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-18 22:18 EDT by Jonathan Pryor
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 18:17:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Pryor 2002-06-18 22:18:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
The Windows key (often lying between the Ctrl and Alt keys on newer keyboards)
is not recognozed modifier key for keyboard shortcuts.

This prevents me from using it to, e.g., assign <Windows>-r to open the Run
Program applet.

What I find particularly interesting is that I was able to use the Windows key
on Red Hat 7.1 to do the same thing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I'm unable to exactly reproduce this, as I've since thrown Ximian Gnome and
Gnome 2 snapshots on this machine.  I'm still unable to use the Windows key for
shortcuts, however.

1. Open Control Center
2. Find the applet that allows you to set the shortcut to open the Run Program
dialog box.
3. Click the "Set" button (or whatever it happens to be called; I forget)
4. Press <Window Key>-r (the <Window> key and the letter `r' at the same time.)


Actual Results:  Notice that `r' is the shortcut key, not <Win>-r (or some
equivalent).

If you accept these settings, just pressing `r' (without pressing the Windows
key) will launch the run dialog box.  This is undesirable.

Expected Results:  The applet would allow the Windows key to be used as a
shortcut modifier key, much like the Ctrl and Alt keys are.

This would imply that the dialog would say <Win>-r (or equivalent) after
pressing the shortcut combination, and that pressing <Win>-r would launch the
Run Program dialog.

Additional info:
Comment 1 Havoc Pennington 2002-07-10 18:42:25 EDT
(This is a duplicate of another bug in here somewhere)
Comment 2 Havoc Pennington 2002-12-19 18:17:11 EST
This should work in rawhide and the next beta. Reopen if not.

Note You need to log in before you can comment on or make changes to this bug.