Bug 66957 - kmail crashes if it is confused by ~/Mail
kmail crashes if it is confused by ~/Mail
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-18 23:58 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:30:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-18 23:58:53 EDT
Description of Problem:
If kmail finds something that it doesn't understand in ~/Mail it crashes 
rather than giving an error message.  This is especially annoying because 
one of the things that it doesn't understand is the contents of a ~/Mail 
directory created with earlier versions of kmail (e.g. from KDE 1.2).  So, 
a user upgrading from KDE 1.2 finds that their kmail just crashes every 
time they try to run it with no explanation.  It would be much nicer if it 
offered to convert the ~/Mail over to the new format, but at the very least 
it should give a message explaining what is wrong.

Version-Release number of selected component (if applicable):
3.0.0-4

How Reproducible:
Always

Steps to Reproduce:
1. See description.
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Petr Rockai 2006-07-17 14:37:17 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 2 Bill Nottingham 2006-10-18 14:30:41 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.