Bug 66962 - XtAddCallback runtime errors when compiling against OpenMotif
XtAddCallback runtime errors when compiling against OpenMotif
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: openmotif (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-19 01:44 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-19 01:45:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example source code illustrating the bug (735 bytes, text/plain)
2002-06-19 01:45 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-06-19 01:44:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
When compiling my own app. with the RH7.3 rpms of OpenMotif 2.2.2-5 I see
several runtime errors: 'Warning: Cannot find callback list in XtAddCallback',
and the app doesn't work as expected. When compiling against OpenMotif
2.2.2-3_ICS, found on www.openmotif.org there is no problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.compile attached file 'hello.c' with gcc hello.c -o hello -I/usr/X11R6/include
-L/usr/X11R6/lib -lXm -lXt -lX11 -lXm
2. Execute ./hello

	

Actual Results:  Notice that the label on the button is wrong ("pushme") and
when pushed nothing is printed.

Expected Results:  The label on the button should read "Push here to say hello"
and when pushed is should read "Hello!" in the terminal window.

Additional info:

Upgraded from RH7.2
Comment 1 Need Real Name 2002-06-19 01:45:15 EDT
Created attachment 61524 [details]
Example source code illustrating the bug
Comment 2 Ngo Than 2002-06-19 04:49:51 EDT
i cannot reproduce this problem with your hello.c, It worked as expected.
Comment 3 Terry Griffin 2002-12-02 16:46:31 EST
Count me in as one that can create (and not avoid) this problem.
I have a fully updated RH 7.3 system with openmotif-2.2.2-5.

Poking around the net, from what other's are saying it may depend
on which X server you're running. I'm running XFree86-4.2.0-8 with
XF86_SVGA from XFree86-SVGA-3.3.6-4.

Just to make sure, I uninstalled all lesstif packages to make sure
it wasn't interfering in some way.

Note You need to log in before you can comment on or make changes to this bug.