This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 669668 - SELinux is preventing systemd-readahe from 'write' accesses on the file /usr/sbin/setroubleshootd.
SELinux is preventing systemd-readahe from 'write' accesses on the file /usr/...
Status: CLOSED DUPLICATE of bug 669672
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:625a2ee6b45...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-14 06:54 EST by satellitgo
Modified: 2011-01-14 09:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-14 09:15:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description satellitgo 2011-01-14 06:54:18 EST
SELinux is preventing systemd-readahe from 'write' accesses on the file /usr/sbin/setroubleshootd.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that systemd-readahe should be allowed write access on the setroubleshootd file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-readahe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:readahead_t:s0
Target Context                system_u:object_r:setroubleshootd_exec_t:s0
Target Objects                /usr/sbin/setroubleshootd [ file ]
Source                        systemd-readahe
Source Path                   systemd-readahe
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           setroubleshoot-server-3.0.20-1.fc15
Policy RPM                    selinux-policy-3.9.12-6.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.37-2.fc15.i686 #1
                              SMP Fri Jan 7 15:46:20 UTC 2011 i686 i686
Alert Count                   1
First Seen                    Fri 14 Jan 2011 08:49:16 AM EST
Last Seen                     Fri 14 Jan 2011 08:49:16 AM EST
Local ID                      ab88b380-0298-4ead-840d-9b1ba66d499a

Raw Audit Messages
type=AVC msg=audit(1295012956.716:126): avc:  denied  { write } for  pid=444 comm="systemd-readahe" path="/usr/sbin/setroubleshootd" dev=dm-0 ino=34148 scontext=system_u:system_r:readahead_t:s0 tcontext=system_u:object_r:setroubleshootd_exec_t:s0 tclass=file


Hash: systemd-readahe,readahead_t,setroubleshootd_exec_t,file,write

audit2allow

#============= readahead_t ==============
allow readahead_t setroubleshootd_exec_t:file write;

audit2allow -R

#============= readahead_t ==============
allow readahead_t setroubleshootd_exec_t:file write;
Comment 1 Daniel Walsh 2011-01-14 09:15:30 EST

*** This bug has been marked as a duplicate of bug 669672 ***

Note You need to log in before you can comment on or make changes to this bug.