Bug 669670 - SELinux is preventing systemd-readahe from 'write' accesses on the file /usr/sbin/irqbalance.
SELinux is preventing systemd-readahe from 'write' accesses on the file /usr/...
Status: CLOSED DUPLICATE of bug 669672
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:09b1d352a0a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-14 06:56 EST by satellitgo
Modified: 2011-01-14 09:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-14 09:15:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description satellitgo 2011-01-14 06:56:07 EST
SELinux is preventing systemd-readahe from 'write' accesses on the file /usr/sbin/irqbalance.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that systemd-readahe should be allowed write access on the irqbalance file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-readahe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:readahead_t:s0
Target Context                system_u:object_r:irqbalance_exec_t:s0
Target Objects                /usr/sbin/irqbalance [ file ]
Source                        systemd-readahe
Source Path                   systemd-readahe
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           irqbalance-0.56-1.fc14
Policy RPM                    selinux-policy-3.9.12-6.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.37-2.fc15.i686 #1
                              SMP Fri Jan 7 15:46:20 UTC 2011 i686 i686
Alert Count                   1
First Seen                    Fri 14 Jan 2011 08:49:17 AM EST
Last Seen                     Fri 14 Jan 2011 08:49:17 AM EST
Local ID                      33fb81e4-97b7-4d75-adce-29b53486b678

Raw Audit Messages
type=AVC msg=audit(1295012957.74:131): avc:  denied  { write } for  pid=444 comm="systemd-readahe" path="/usr/sbin/irqbalance" dev=dm-0 ino=21790 scontext=system_u:system_r:readahead_t:s0 tcontext=system_u:object_r:irqbalance_exec_t:s0 tclass=file


Hash: systemd-readahe,readahead_t,irqbalance_exec_t,file,write

audit2allow

#============= readahead_t ==============
allow readahead_t irqbalance_exec_t:file write;

audit2allow -R

#============= readahead_t ==============
allow readahead_t irqbalance_exec_t:file write;
Comment 1 Daniel Walsh 2011-01-14 09:15:14 EST

*** This bug has been marked as a duplicate of bug 669672 ***

Note You need to log in before you can comment on or make changes to this bug.