Bug 669780 - x11vnc gui -> Error: tail: cannot watch `/tmp/x11vnc.tray.xxxxx'
Summary: x11vnc gui -> Error: tail: cannot watch `/tmp/x11vnc.tray.xxxxx'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: x11vnc
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-14 18:47 UTC by Orion Poplawski
Modified: 2012-01-16 19:31 UTC (History)
1 user (show)

Fixed In Version: x11vnc-0.9.13-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-11 15:27:31 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2011-01-14 18:47:00 UTC
Description of problem:

[orion@orca ~]$ x11vnc -gui tray=setpass -rfbport 5900 -bg -o ~/.x11vnc.log
starting gui, trying display: :0
14/01/2011 11:40:44 icon_mode_file=/tmp/x11vnc.tray.2R8UaV
PORT=5900
[orion@orca ~]$ 
14/01/2011 11:40:44 gui: got SIGUSR1
14/01/2011 11:40:44 gui: ping succeeded.
ps -fe | grep vnc
orion    18628     1  0 11:40 ?        00:00:00 x11vnc -gui tray=setpass -rfbport 5900 -bg -o /export/home/orion/.x11vnc.log
orion    18635 18627  0 11:40 pts/3    00:00:00 [x11vnc] <defunct>
orion    18804  2238  0 11:44 pts/3    00:00:00 grep --color=auto vnc

Yields dialog box with:

tail: cannot watch `/tmp/x11vnc.tray.2R8UaV': No such file or directory
tail: cannot watch `/tmp/x11vnc.tray.2R8UaV': No such file or directory
    while executing
"close $channel"
    (procedure "read_client_info" line 25)
    invoked from within
"read_client_info $client_tail"
    (procedure "read_client_tail" line 5)
    invoked from within
"read_client_tail"

Version-Release number of selected component (if applicable):
x11vnc-0.9.8-14.fc13.i686

How reproducible:
Every time

Comment 1 Pavel Alexeev 2011-01-14 20:31:09 UTC
Hello. Firstlay thank you for the bugreport.

Please can you try new version from rawhide, is it fix problem or not?

Comment 2 Orion Poplawski 2011-01-18 17:38:55 UTC
Same error with x11vnc-0.9.12-15.fc15.i686

Comment 3 Pavel Alexeev 2011-01-19 16:44:23 UTC
(In reply to comment #0)
> Yields dialog box with:
When it happened? How reproduce?

I run as you wrote, it seams runned. What next?

Comment 4 Orion Poplawski 2011-01-20 18:01:24 UTC
Looks like a race condition.  It looks like x11vnc forks and one process exits and on exit cleans up the icon_mode_file.  Works for me sometimes, but not others.

Comment 5 Pavel Alexeev 2011-01-20 20:37:35 UTC
Ohh, if it is not always reproducable it will hard to fix.
Can you try provide reproducable and conditions for that?

Comment 6 Orion Poplawski 2011-11-22 21:16:32 UTC
According to http://www.karlrunge.com/x11vnc/#beta-test this is fixed in 0.9.13:

Fix race condition in tkx11vnc gui where the comm file may be deleted before tail opens it.

I built it locally and it seems to work.  Don't seem to need x11vnc-0.9.8-XShm-explicit-include.patch anymore either.

Comment 7 Pavel Alexeev 2011-12-11 15:27:31 UTC
Thanks.
I hope it really fixed in this version.

Please check that build http://koji.fedoraproject.org/koji/taskinfo?taskID=3577890

Comment 8 Orion Poplawski 2011-12-14 22:42:17 UTC
Any chance of F16/F15 updates please?

Comment 9 Pavel Alexeev 2011-12-19 10:23:17 UTC
Could you please test it before? I think it should not have excessive dependencies. If it works I'll submit updates for the stable branches. Or you want scratch build for that?

Comment 10 Orion Poplawski 2011-12-20 22:35:00 UTC
tested it here and it works fine on F16.

Comment 11 Fedora Update System 2012-01-01 16:05:54 UTC
x11vnc-0.9.13-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/x11vnc-0.9.13-1.fc16

Comment 12 Fedora Update System 2012-01-01 16:06:31 UTC
x11vnc-0.9.13-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/x11vnc-0.9.13-1.fc15

Comment 13 Fedora Update System 2012-01-01 16:06:51 UTC
x11vnc-0.9.13-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/x11vnc-0.9.13-1.el6

Comment 14 Fedora Update System 2012-01-01 16:07:09 UTC
x11vnc-0.9.13-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/x11vnc-0.9.13-1.el5

Comment 15 Pavel Alexeev 2012-01-01 16:07:43 UTC
Thanks for the help.

Comment 16 Fedora Update System 2012-01-11 06:04:38 UTC
x11vnc-0.9.13-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2012-01-11 06:15:13 UTC
x11vnc-0.9.13-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2012-01-16 19:31:27 UTC
x11vnc-0.9.13-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2012-01-16 19:31:36 UTC
x11vnc-0.9.13-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.