Bug 669803 - Virt manager does not launch without --no-fork
Virt manager does not launch without --no-fork
Status: CLOSED DUPLICATE of bug 677020
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-14 15:33 EST by Eric Paris
Modified: 2011-03-28 16:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-28 16:13:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace of virt-manager failing to start (792.04 KB, application/octet-stream)
2011-01-14 15:33 EST, Eric Paris
no flags Details

  None (edit)
Description Eric Paris 2011-01-14 15:33:25 EST
Created attachment 473582 [details]
strace of virt-manager failing to start

virt-manager-0.8.5-1.fc15.noarch
dbus-1.4.0-2.fc14.x86_64
libvirt-0.8.7-1.fc15.x86_64

This is F15 up2date as of 1/14/11.  If I launch virt-manager it will return to the command line and virt-manager will be running in the backgroup, but the gui never pops up and it never does anything.  The only messages it prints in the log are:

$ tail -f ~/.virt-manager/virt-manager.log
[Fri, 14 Jan 2011 14:26:40 virt-manager 7555] INFO (virt-manager:161) Application startup
[Fri, 14 Jan 2011 14:26:40 virt-manager 7555] DEBUG (virt-manager:300) Launched as: /usr/share/virt-manager/virt-manager.py

If I use --no-fork the log goes on like so:
$ tail -f ~/.virt-manager/virt-manager.log
[Fri, 14 Jan 2011 14:27:47 virt-manager 7741] INFO (virt-manager:161) Application startup
[Fri, 14 Jan 2011 14:27:47 virt-manager 7741] DEBUG (virt-manager:300) Launched as: /usr/share/virt-manager/virt-manager.py --debug
[Fri, 14 Jan 2011 14:27:47 virt-manager 7741] DEBUG (engine:348) About to connect to uris ['qemu+ssh://root@paris.rdu.redhat.com/system', 'qemu:///system']
[Fri, 14 Jan 2011 14:27:47 virt-manager 7741] DEBUG (engine:643) window counter incremented to 1
[Fri, 14 Jan 2011 14:27:47 virt-manager 7741] DEBUG (connection:848) Scheduling background open thread for qemu:///system
[Fri, 14 Jan 2011 14:27:47 virt-manager 7741] DEBUG (connection:993) Background thread is running

I'll attach an strace I captured of the problem.  The last couple of line look like so:

10426 connect(22, {sa_family=AF_FILE, path=@"/tmp/dbus-5n4DrpUX"...}, 21) = 0
10426 geteuid()                         = 4166
10426 getegid()                         = 4166
10426 geteuid()                         = 4166
10426 getegid()                         = 4166
10426 poll([{fd=22, events=POLLOUT}], 1, -1) = 1 ([{fd=22, revents=POLLOUT}])
10426 sendmsg(22, {msg_name(0)=NULL, msg_iov(1)=[{"\0", 1}], msg_controllen=32, {cmsg_len=28, cmsg_level=SOL_SOCKET, cmsg_type=SCM_CREDENTIALS{pid=10426, uid=4166, gid=4166}}, msg_flags=0}, MSG_NOSIGNAL) = 1
10426 poll([{fd=22, events=POLLOUT}], 1, -1) = 1 ([{fd=22, revents=POLLOUT}])
10426 sendto(22, "AUTH\r\n", 6, MSG_NOSIGNAL, NULL, 0) = 6
10426 poll([{fd=22, events=POLLIN}], 1, -1) = 1 ([{fd=22, revents=POLLIN}])
10426 recvfrom(22, "REJECTED EXTERNAL ANONYMOUS DBUS"..., 4096, 0, NULL, NULL) = 46
10426 poll([{fd=22, events=POLLOUT}], 1, -1) = 1 ([{fd=22, revents=POLLOUT}])
10426 sendto(22, "AUTH EXTERNAL 34313636\r\n", 24, MSG_NOSIGNAL, NULL, 0) = 24
10426 poll([{fd=22, events=POLLIN}], 1, -1) = 1 ([{fd=22, revents=POLLIN}])
10426 recvfrom(22, "OK 3aa614414c20db9c5350a21a4d309"..., 4096, 0, NULL, NULL) = 37
10426 poll([{fd=22, events=POLLOUT}], 1, -1) = 1 ([{fd=22, revents=POLLOUT}])
10426 sendto(22, "NEGOTIATE_UNIX_FD\r\n", 19, MSG_NOSIGNAL, NULL, 0) = 19
10426 poll([{fd=22, events=POLLIN}], 1, -1) = 1 ([{fd=22, revents=POLLIN}])
10426 recvfrom(22, "AGREE_UNIX_FD\r\n", 4096, 0, NULL, NULL) = 15
10426 poll([{fd=22, events=POLLOUT}], 1, -1) = 1 ([{fd=22, revents=POLLOUT}])
10426 sendto(22, "BEGIN\r\n", 7, MSG_NOSIGNAL, NULL, 0) = 7
10426 write(10, "A", 1)                 = 1
10426 sched_yield()                     = 0
10426 sched_yield()                     = 0
10426 sched_yield()                     = 0

and then sched_yield() go on and on and on and on and on
Comment 1 Eric Paris 2011-02-15 15:17:00 EST
So this has changed a bit with updates to F15.  virt-manager now launches.  I can connect to a remote box over ssh.  But when I try to double click on a guest name it hangs.  I have to kill virt-manager.  If I use --no-fork I am able to open guests.....
Comment 2 Cole Robinson 2011-03-28 16:13:11 EDT

*** This bug has been marked as a duplicate of bug 677020 ***

Note You need to log in before you can comment on or make changes to this bug.