Bug 669854 - Latest Gnome-Shell will not work correctly without 3D drivers preinstalled
Latest Gnome-Shell will not work correctly without 3D drivers preinstalled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-14 22:15 EST by Greg`
Modified: 2011-02-18 11:49 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-18 11:49:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Greg` 2011-01-14 22:15:33 EST
Description of problem: when running the LiveCD ( latest Compose ) dated the 14/01/2011 the Gnome-Shell will load but using anything in the Shell is impossible without 3D drivers installed like the experimental driver


Version-Release number of selected component (if applicable):


How reproducible:
same as Above in Description 

Steps to Reproduce:
1. torch up  latest LiveCD
2. try to use anything in Gnome-shell
3. only way to use it completely is to have 3D drivers preinstalled
  
Actual results:
everything should work without a problem

Expected results:


Additional info:
Comment 1 Adam Williamson 2011-01-18 18:05:39 EST
there's a few issues here:

GNOME Shell detection of necessary graphics driver capabilities is a difficult problem which isn't entirely solved yet; this is an upstream thing and one the team's certainly well aware of, there's a whole page about it somewhere. I think we probably don't need a Fedora bug to track it.

On the Fedora side, we could perhaps add mesa-dri-drivers-experimental into the nightlies, at least for now. CCing a few people for thoughts on that.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Gianluca Sforna 2011-02-18 06:12:35 EST
Is the experimental package still around? I tried installing it on my liveusb but got:

No package mesa-dri-drivers-experimental available
Comment 3 Adam Williamson 2011-02-18 11:49:49 EST
no, we merged the nouveau driver into the main drivers package now, which effectively resolves this.

Note You need to log in before you can comment on or make changes to this bug.