Bug 669856 - gnash module won't load in python
Summary: gnash module won't load in python
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnash
Version: 13
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Hicham HAOUARI
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-15 04:04 UTC by Bob Nolty
Modified: 2011-03-27 19:35 UTC (History)
9 users (show)

Fixed In Version: gnash-0.8.9-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-18 03:59:47 UTC


Attachments (Terms of Use)

Description Bob Nolty 2011-01-15 04:04:10 UTC
Description of problem:

[nolty@BobVirtF13 ~]$ python
Python 2.6.4 (r264:75706, Jun  4 2010, 18:20:16) 
[GCC 4.4.4 20100503 (Red Hat 4.4.4-2)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gnash
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: /usr/lib/python2.6/site-packages/gtk-2.0/gnash.so: undefined symbol: _ZN5gnash19create_Renderer_aggEPKc
>>> 

This looks like a packaging inconsistency.  In the gnash RPM, symbol _ZN5gnash19create_Renderer_aggEPKc lives in /usr/lib/gnash/libgnashrender.so.  In the python-gnash RPM, the gnash python module is in 
/usr/lib/python2.6/site-packages/gtk-2.0/gnash.so.  That .so references the create_Renderer_agg symbol mentioned above, but does not mention the libgnashrender library (it does mention four gnash libraries, libgnashcore, -base, -sound and -media).



Version-Release number of selected component (if applicable):

gnash-0.8.8-4.fc13.i686
python-gnash-0.8.8-4.fc13.i686


How reproducible:

Every time.


Steps to Reproduce:
1. Start python
2. type 'import gnash'
3.
  
Actual results:

ImportError with traceback, shown above

Expected results:

module loads


Additional info:

Comment 1 Dave Malcolm 2011-01-17 17:13:09 UTC
Thanks for filing this bug report.

"python-gnash" is built as part of the "gnash" src.rpm, so I'm reassigning this bug to the "gnash" component.

Looks like a bug in how /usr/lib/python2.6/site-packages/gtk-2.0/gnash.so is linked.

BTW, c++filt indicates that "_ZN5gnash19create_Renderer_aggEPKc"
is the mangled form of this C++ symbol "gnash::create_Renderer_agg(char const*)

Comment 2 Fedora Admin XMLRPC Client 2011-01-29 22:10:06 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Fedora Admin XMLRPC Client 2011-01-29 22:11:04 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Hicham HAOUARI 2011-02-18 14:37:55 UTC
This should be fixed in the next release

Comment 5 Fedora Update System 2011-03-13 16:53:26 UTC
gnash-0.8.9-0.1.20110312git.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnash-0.8.9-0.1.20110312git.fc14

Comment 6 Fedora Update System 2011-03-13 16:55:59 UTC
gnash-0.8.9-0.1.20110312git.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnash-0.8.9-0.1.20110312git.fc13

Comment 7 Fedora Update System 2011-03-13 16:58:28 UTC
gnash-0.8.9-0.1.20110312git.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnash-0.8.9-0.1.20110312git.fc15

Comment 8 Fedora Update System 2011-03-18 03:57:17 UTC
gnash-0.8.9-0.1.20110312git.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-03-19 02:15:11 UTC
gnash-0.8.9-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnash-0.8.9-1.fc14

Comment 10 Fedora Update System 2011-03-19 02:22:37 UTC
gnash-0.8.9-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnash-0.8.9-1.fc13

Comment 11 Fedora Update System 2011-03-27 19:24:52 UTC
gnash-0.8.9-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-03-27 19:32:22 UTC
gnash-0.8.9-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.