Bug 669883 - [abrt] audacity-1.3.12-0.6.beta.fc14: mask_inline.h:160: snd_mask_leave: Assertion `val <= 64' failed. (SIGABRT)
Summary: [abrt] audacity-1.3.12-0.6.beta.fc14: mask_inline.h:160: snd_mask_leave: Asse...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audacity
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Manuel F Martinez
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3821eb78fb213601bd4b65ff1a2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-15 12:30 UTC by Omar Hashim
Modified: 2011-05-25 02:53 UTC (History)
2 users (show)

Fixed In Version: audacity-1.3.13-0.4.beta.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-25 02:53:12 UTC


Attachments (Terms of Use)
File: backtrace (61.39 KB, text/plain)
2011-01-15 12:30 UTC, Omar Hashim
no flags Details

Description Omar Hashim 2011-01-15 12:30:57 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: audacity
comment: Audacity crashes when trying to change sound output from default.
component: audacity
crash_function: snd_mask_leave
executable: /usr/bin/audacity
kernel: 2.6.37-sealinkos
package: audacity-1.3.12-0.6.beta.fc14
rating: 4
reason: Process /usr/bin/audacity was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1295094488
uid: 500

How to reproduce
-----
1.audacity>preferences>interfaces
2.change default output to another card.
3.audacity crashes.

Comment 1 Omar Hashim 2011-01-15 12:30:59 UTC
Created attachment 473640 [details]
File: backtrace

Comment 2 David Timms 2011-01-15 13:17:56 UTC
What entry was showing originally ?

At what point did it crash ?
eg clicking a drop down, choosing an item.. ?

Comment 3 Omar Hashim 2011-01-15 21:04:11 UTC
(In reply to comment #2)
> What entry was showing originally ?
> Default
> At what point did it crash ?
> eg clicking a drop down, choosing an item.. ?
yes. clicking a drop down,choosing an item, even if it was your default sound card
and then clicking ok.

Comment 4 David Timms 2011-01-15 23:32:54 UTC
I am unable to reproduce this. I:
- start audacity
- edit|preferences
- devices
- playback: device = default  (at startup)

- drop down the list (no crash)
- select pulse, dmix, front, all without a crash
- no crash either at clicking OK in the Prefs dialog.

Omar: if you repeat your steps, does it happen every time ?

has it only happened since audacity-1.3.12-0.6 ?

is pulseaudio playback working in another audio application like audacious ?

is it repeatable after reverting to an older version ?: (try)
yum distribution-synchronization audacity
  or
yum downgrade audacity-1.3.12-0.4.beta.fc14

Comment 5 Omar Hashim 2011-01-16 06:43:52 UTC
(In reply to comment #4)
> I am unable to reproduce this. I:
> - start audacity
> - edit|preferences
> - devices
> - playback: device = default  (at startup)
> 
> - drop down the list (no crash)
> - select pulse, dmix, front, all without a crash
> - no crash either at clicking OK in the Prefs dialog.
> 
> Omar: if you repeat your steps, does it happen every time ?
> yes
> has it only happened since audacity-1.3.12-0.6 ?
> yes
> is pulseaudio playback working in another audio application like audacious ?
> yes
> is it repeatable after reverting to an older version ?: (try)
> yum distribution-synchronization audacity
>   or
> yum downgrade audacity-1.3.12-0.4.beta.fc14

Basically I am using a usb sound card.  Audacity plays through it fine set on default. If I choose the card itself in drop-down Audacity crashes. every other  option such as pulse, dmix etc. works.  I think it is just a technicality and not much of an issue.

Comment 6 Fedora Update System 2011-04-27 22:11:27 UTC
audacity-1.3.13-0.3.beta.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/audacity-1.3.13-0.3.beta.fc14

Comment 7 Fedora Update System 2011-04-29 03:22:20 UTC
Package audacity-1.3.13-0.3.beta.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing audacity-1.3.13-0.3.beta.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/audacity-1.3.13-0.3.beta.fc14
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-05-05 22:40:28 UTC
audacity-1.3.13-0.4.beta.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/audacity-1.3.13-0.4.beta.fc14

Comment 9 Fedora Update System 2011-05-25 02:52:23 UTC
audacity-1.3.13-0.4.beta.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.