Bug 669931 - SELinux is preventing systemd-readahe from 'write' accesses on the directory /etc/gconf/gconf.xml.mandatory.
SELinux is preventing systemd-readahe from 'write' accesses on the directory ...
Status: CLOSED DUPLICATE of bug 669672
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:dd7744cee5d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-15 16:31 EST by Joachim Frieben
Modified: 2011-01-17 05:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-17 05:33:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2011-01-15 16:31:54 EST
SELinux is preventing systemd-readahe from 'write' accesses on the directory /etc/gconf/gconf.xml.mandatory.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that systemd-readahe should be allowed write access on the gconf.xml.mandatory directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-readahe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:readahead_t:s0
Target Context                system_u:object_r:gconf_etc_t:s0
Target Objects                /etc/gconf/gconf.xml.mandatory [ dir ]
Source                        systemd-readahe
Source Path                   systemd-readahe
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           GConf2-2.32.1-3.fc15
Policy RPM                    selinux-policy-3.9.12-7.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.37-2.fc15.x86_64 #1 SMP Fri Jan 7
                              14:57:36 UTC 2011 x86_64 x86_64
Alert Count                   1
First Seen                    Sat 15 Jan 2011 03:01:01 PM CET
Last Seen                     Sat 15 Jan 2011 03:01:01 PM CET
Local ID                      b9e51d9b-dedc-4ca2-9f37-e4e39f8beb46

Raw Audit Messages
type=AVC msg=audit(1295100061.674:208): avc:  denied  { write } for  pid=494 comm="systemd-readahe" path="/etc/gconf/gconf.xml.mandatory" dev=dm-0 ino=18641 scontext=system_u:system_r:readahead_t:s0 tcontext=system_u:object_r:gconf_etc_t:s0 tclass=dir


Hash: systemd-readahe,readahead_t,gconf_etc_t,dir,write

audit2allow

#============= readahead_t ==============
#!!!! The source type 'readahead_t' can write to a 'dir' of the following types:
# root_t, var_run_t, readahead_var_lib_t, readahead_var_run_t, root_t

allow readahead_t gconf_etc_t:dir write;

audit2allow -R

#============= readahead_t ==============
#!!!! The source type 'readahead_t' can write to a 'dir' of the following types:
# root_t, var_run_t, readahead_var_lib_t, readahead_var_run_t, root_t

allow readahead_t gconf_etc_t:dir write;
Comment 1 Joachim Frieben 2011-01-15 16:34:33 EST
There are dozens of similar alerts for other files.
Comment 2 Miroslav Grepl 2011-01-17 05:33:41 EST

*** This bug has been marked as a duplicate of bug 669672 ***

Note You need to log in before you can comment on or make changes to this bug.