Bug 67005 - Cannot configure different PCMCIA network cards differently
Cannot configure different PCMCIA network cards differently
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: rcn-7.3
  Show dependency treegraph
 
Reported: 2002-06-19 09:53 EDT by diego.santacruz
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-05 10:14:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot (8.93 KB, image/png)
2002-06-26 06:24 EDT, Harald Hoyer
no flags Details

  None (edit)
Description diego.santacruz 2002-06-19 09:53:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
I have two PCMCIA network cards with my laptop. One is an ethernet card while
the other is a wireless one.
The redhat network configurator (neat), or the network scripts, do not let me
specify different configurations for the different cards.
I need different setups, since the wired ethernet has a static address, while
the wireless one has a hdcp assigned one.
The problem stems from the fact that at any time I have only one of the cards
plugged, and whatever the card it comes up as eth0 and thus tries to use the
same configuration.

Version-Release number of selected component (if applicable):
redhat-config-network-0.9.10-2
initscripts-6.43-1
kernel-pcmcia-cs-3.1.27-10

How reproducible:
Always

Steps to Reproduce:
1. insert the wired ethernet pcmcia card
2. the iface comes up as eth0 and uses that config
3. eject the wired card
4. insert the wireless pcmcia card
5. the iface comes up as eth0 too
6. the network config used is that of the wired setup
	

Actual Results:  When the wireless card is inserted the network setup is
incorrect (ip address, gateway, etc.) since it uses teh one from the wired setup.

Expected Results:  Being able to (optionally) specify a different setup for
different pcmcia network cards. For example, something based on the MAC address,
or the MAC address family (i.e. the manufacturer part).

Additional info:
Comment 1 Harald Hoyer 2002-06-26 06:23:27 EDT
just make the one ethernet card eth1 and bind it to the MAC address..
see attached snapshot...
Comment 2 Harald Hoyer 2002-06-26 06:24:20 EDT
Created attachment 62704 [details]
snapshot
Comment 3 diego.santacruz 2002-06-26 07:24:15 EDT
I cannot make one ethernet card eth1 since it's PCMCIA.

If I make one of the cards eth1 (as in snapshot), then it will not come up when
I insert it into the PCMCIA slot, since PCMCIA will always give eth0 as the name
of the device and hotplug will thus execute "ifup eth0". Then ifup will take the
/etc/sysconfig/network-scripts/ifcfg-eth0 config file (which is for the other
card). It will notice that the HWADDR does not match, and will try to name eth0
the device with the HWADDR in icfg-eth0, which is not the one that I inserted,
so it bails out and the network is not started.

I guess that either pcmcia should find a suitable name to give to the inserted
interface (in this case eth1) or that ifup should have some mechanism so handle
the fact that eth0 can refer to one of a set of interfaces (or something of the
like).

Packages:
kernel-pcmcia-cs-3.1.27-10
initscripts-6.67-1
hotplug-2001_04_24-11
Comment 4 Harald Hoyer 2002-10-23 05:43:46 EDT
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.
Comment 5 diego.santacruz 2002-10-23 06:01:52 EDT
Sorry, but now I'm running RedHat 8.0 which has redhat-config-network-1.1.20-1,
so I cannot test the change.
Comment 6 Harald Hoyer 2002-10-23 06:14:24 EDT
does it work to assign both devices to eth0?
you may also use profiles..
Comment 7 diego.santacruz 2002-10-23 07:19:44 EDT
Under RedHat 8.0 it is not possible to assign both devices to eth0, unless they
appear under different profiles. Not very user-friendly to have to switch
profiles in order to plug another card, but at least there is an option.

I think that when it comes to pluggable network cards (such as PCMCIA) it should
be possible to bind the configuration to the card (maybe by checking its MAC
address) and not to a device name (such as eth0).

Note You need to log in before you can comment on or make changes to this bug.