Bug 670088 - Review Request: smlnj - Standard ML of New Jersey
Summary: Review Request: smlnj - Standard ML of New Jersey
Keywords:
Status: CLOSED DUPLICATE of bug 1421506
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: FE-DEADREVIEW
TreeView+ depends on / blocked
 
Reported: 2011-01-17 07:16 UTC by Ricky Zhou
Modified: 2017-05-26 17:48 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 14:57:37 UTC
Type: ---


Attachments (Terms of Use)

Description Ricky Zhou 2011-01-17 07:16:24 UTC
Spec URL: http://ricky.fedorapeople.org/pkgs/smlnj/smlnj.spec
SRPM URL: http://ricky.fedorapeople.org/pkgs/smlnj/smlnj-110.72-1.fc14.src.rpm
Description:
Standard ML of New Jersey (SML/NJ) is a compiler and programming environment
for the Standard ML programming language. It was originally developed jointly
at Bell Laboratories and Princeton University, and is now a joint project
between researchers at Bell Laboratories, Lucent Technologies), Princeton
University, Yale University (The FLINT Project), and AT&T Research.

Comment 1 Ricky Zhou 2011-05-30 07:20:16 UTC
Spec URL: http://ricky.fedorapeople.org/pkgs/smlnj/smlnj.spec
SRPM URL: http://ricky.fedorapeople.org/pkgs/smlnj/smlnj-110.73-1.fc15.src.rpm

Updated to latest upstream version (110.73).

Comment 2 Brock Organ 2011-10-21 14:06:45 UTC
(In reply to comment #1)
> Spec URL: http://ricky.fedorapeople.org/pkgs/smlnj/smlnj.spec
> SRPM URL: http://ricky.fedorapeople.org/pkgs/smlnj/smlnj-110.73-1.fc15.src.rpm
> 
> Updated to latest upstream version (110.73).

I'm not able to build with this spec file using F14:

$ rpmbuild -ba smlnj.spec 
error: Architecture is not included: x86_64
$ 

Here are the steps to reproduce:

wget http://ricky.fedorapeople.org/pkgs/smlnj/smlnj-110.73-1.fc15.src.rpm
rpm -Uvh smlnj-110.73-1.fc15.src.rpm
cd rpmbuild/SPECS/
rpmbuild -ba smlnj.spec

Regards,

Brock

Comment 3 Brock Organ 2011-10-21 14:09:24 UTC
(In reply to comment #2)
> I'm not able to build with this spec file using F14:
> 
> $ rpmbuild -ba smlnj.spec 
> error: Architecture is not included: x86_64
> $ 

I get the same error with F15 on x86_64 ...

Comment 4 Ricky Zhou 2011-10-21 16:21:02 UTC
Hey, glad to have some eyes on this package :-)

It doesn't build on x86_64 because smlnj does not support x86_64 (see the last FAQ entry at http://www.smlnj.org/dist/working/110.73/NOTES/INSTALL).  Luckily,  the 32-bit version builds and runs fine on an x86_64 machine.  Just install glibc-devel.i686 and libgcc.i686, and you should be able to build it with rpmbuild --target i686 -ba smlnj.spec (I usually find it more convenient to just do a koji scratch build though).

Comment 5 Brock Organ 2011-10-22 15:29:00 UTC
(In reply to comment #4)
> Hey, glad to have some eyes on this package :-)

Hi Ricky,

Glad to help, thank you for your packages! :D

> 
> It doesn't build on x86_64 because smlnj does not support x86_64 (see the last
> FAQ entry at http://www.smlnj.org/dist/working/110.73/NOTES/INSTALL).  Luckily,
>  the 32-bit version builds and runs fine on an x86_64 machine.  Just install
> glibc-devel.i686 and libgcc.i686, and you should be able to build it with
> rpmbuild --target i686 -ba smlnj.spec (I usually find it more convenient to
> just do a koji scratch build though).

From a fresh F15 install (needed because the glibc-devel.i686 and libcc.i686 packages need to match n-v-r with the already installed ones, and an older F15 install might not match) I was able to download, compile from source, and install the smlnj packages from your url:

yum -y install glibc-devel.i686 libgcc.i686
wget http://ricky.fedorapeople.org/pkgs/smlnj/smlnj-110.73-1.fc15.src.rpm
rpm -Uvh smlnj-110.73-1.fc15.src.rpm
cd rpmbuild/SPECS/
rpmbuild --target i686 -ba smlnj.spec
rpm -Uvh /root/rpmbuild/RPMS/i686/smlnj-110.73-1.fc15.i686.rpm
/usr/bin/sml

Thanks for your help, Ricky! :D

Regards,

Brock

Comment 6 Brock Organ 2011-10-22 15:38:49 UTC
(In reply to comment #5)
> From a fresh F15 install 

For others trying to reproduce this behavior, let me be clear:

My fresh F15 install was a default "Software Development" install on x86_64 ...


> yum -y install glibc-devel.i686 libgcc.i686
> wget http://ricky.fedorapeople.org/pkgs/smlnj/smlnj-110.73-1.fc15.src.rpm
> rpm -Uvh smlnj-110.73-1.fc15.src.rpm
> cd rpmbuild/SPECS/
> rpmbuild --target i686 -ba smlnj.spec
> rpm -Uvh /root/rpmbuild/RPMS/i686/smlnj-110.73-1.fc15.i686.rpm
> /usr/bin/sml
> 

Regards,

Brock

Comment 7 Brock Organ 2011-10-22 16:02:51 UTC
Hi Ricky,

What is the next part of the review request?

Regards,

Brock

Comment 8 Iain Arnell 2011-10-24 05:56:22 UTC
Ricky,

it fails to build in rawhide and f16:

./config/install.sh: Using shell /bin/sh.
./config/install.sh: SML root is /builddir/build/BUILD/smlnj-110.73.
./config/install.sh: Installation directory is /builddir/build/BUILD/smlnj-110.73.
./config/install.sh: Installing version 110.73.
./config/install.sh: URL of source archive is http://smlnj.cs.uchicago.edu/dist/working/110.73/.
./config/install.sh: !!! Script /builddir/build/BUILD/smlnj-110.73/bin/.arch-n-opsys fails on this machine.
./config/install.sh: !!! You must patch this by hand and repeat the installation.
error: Bad exit status from /var/tmp/rpm-tmp.Bv0cKg (%build)


Checking bin/.arch-n-opsys, I see that it's explicitly checking `uname -r` against 2.[2-6].* and failing because the kernel's been bumped to 3.x now.

Comment 10 Robert Knight 2012-03-28 13:41:16 UTC
This will let it build on later kernels

diff -uNr config/_arch-n-opsys config-new/_arch-n-opsys
--- config/_arch-n-opsys	2011-03-22 09:30:14.000000000 -0400
+++ config-new/_arch-n-opsys	2012-03-28 08:57:09.729873343 -0400
@@ -94,6 +94,7 @@
 	  2.4.*) ;;
 	  2.5.*) ;;
 	  2.6.*) ;;
+	  3.*) ;;
 	  *) exit 1 ;;
 	esac
 	;;

Comment 11 Iain Arnell 2012-03-28 13:54:25 UTC
Latest upstream version, 110.74 should also build on 3.x kernels.

Comment 12 Rick Elrod 2013-01-14 00:53:53 UTC
This works without modification (except removing ExclusiveArch  + version number changes) with current 110.75.

It would be nice to see this in Fedora, but I don't know enough about it to maintain it, or really even move this review along, but just wanted to mention that it works with the latest version, for anyone who needs it.

Comment 13 James Hogarth 2015-12-04 02:11:55 UTC
There has not been any comment in a long time.

Are you intending to progress this?

If there is no response within a week this bug will be closed as per policy.

https://fedoraproject.org/wiki/Policy_for_stalled_package_reviews

Comment 14 Tom "spot" Callaway 2015-12-04 14:43:22 UTC
(In reply to James Hogarth from comment #13)
> There has not been any comment in a long time.
> 
> Are you intending to progress this?
> 
> If there is no response within a week this bug will be closed as per policy.
> 
> https://fedoraproject.org/wiki/Policy_for_stalled_package_reviews

Ricky no longer works at Red Hat (since Jan 2012).

Comment 15 James Hogarth 2015-12-04 14:57:37 UTC
(In reply to Tom "spot" Callaway from comment #14)
> (In reply to James Hogarth from comment #13)
> > There has not been any comment in a long time.
> > 
> > Are you intending to progress this?
> > 
> > If there is no response within a week this bug will be closed as per policy.
> > 
> > https://fedoraproject.org/wiki/Policy_for_stalled_package_reviews
> 
> Ricky no longer works at Red Hat (since Jan 2012).

Thanks Tom

I'll close this then so that it's not in the queue and if anyone else has interest they can open a fresh review request.

Comment 16 Zbigniew Jędrzejewski-Szmek 2017-05-26 17:48:03 UTC

*** This bug has been marked as a duplicate of bug 1421506 ***


Note You need to log in before you can comment on or make changes to this bug.