Bug 67014 - Evolution alarm does not display the title of the appointment
Evolution alarm does not display the title of the appointment
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-19 11:05 EDT by Diego Novillo
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 19:07:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Diego Novillo 2002-06-19 11:05:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
When evolution triggers an alarm for an appointment, the alarm window does not
show the text entered in the appointment's Summary.  Instead, it displays
'Untitled Appointment'.

This not always happens, though.  I think it's related to either how long the
summary field is or whether you use non-alphanumeric characters.  But I'm not sure.

For instance, if I set the summary to something like 'Company Meeting
xxx-xxx-xxxx / xxx-xxx-xxxx', the alarm window shows up 'Untitled Appointment'.
 But if I set it to something like 'buy some groceries', then it shows up fine.

I also synchronize evolution with my palm.  I don't know if that could be a factor.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Create a new appointment
2.Set the summary field	to something long with non-alphanumeric characters.

Actual Results:  Evolution should shows 'Untitled Appointment' in the alarm window

Expected Results:  Evolution should show the Summary field in the window

Additional info:
Comment 1 Jeremy Katz 2002-06-19 19:18:37 EDT
I can't reproduce this here with some appointments entered by hand... by chance
is it only showing up with things synced from the palm?  If so, I'd almost be
willing to bet it's a conduit bug :(
Comment 2 Diego Novillo 2002-06-19 19:54:40 EDT
Yeah, I think it might be the conduits.  The funny thing is that some
appointments that I have been synchronizing for ages don't get messed up.  A
total mystery :(
Comment 3 Jeremy Katz 2003-02-09 21:43:50 EST
Is this better in 8.0 and/or rawhide?
Comment 4 Diego Novillo 2003-02-10 08:37:53 EST
Yes.  It is rather temperamental though.  It always displays the text that you
type when you first create the appointment.  If you want to change the text of
the reminder, you have to explicitly remove the existing reminder, add a new one
and in the Options for the reminder type the new text.

Awkward, but it works.
Comment 5 Jeremy Katz 2003-07-28 19:07:27 EDT
This looks like it works for me with 1.4.x in rawhide with a quick test.

Note You need to log in before you can comment on or make changes to this bug.