Bug 670381 - /etc/mtab is not a symlink or not pointing to /proc/self/mounts
/etc/mtab is not a symlink or not pointing to /proc/self/mounts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15Alpha/F15AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-01-18 00:20 EST by John Reiser
Modified: 2011-02-09 11:03 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-15.16-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-09 11:03:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2011-01-18 00:20:26 EST
Description of problem: On a freshly-installed system, systemd complains about /etc/mtab.


Version-Release number of selected component (if applicable):
lorax-0.2-2.fc15

How reproducible: every time


Steps to Reproduce:
1. Compose Install DVD from rawhide for x86_64 via pungi [+lorax].
2. Fresh Install DVD, defaults, General Internet desktop.
3. Boot newly-installed system.
  
Actual results:
[    8.045846] systemd[1]: /etc/mtab is not a symlink or not pointing to /proc/self/mounts. This is not supported anymore. Please make sure to replace this file by a symlink to avoid incorrect or misleading mount(8) output.


Expected results: no complaint


Additional info:
Comment 1 Martin Gracik 2011-01-18 06:19:43 EST
This has nothing to do with lorax, if it happens in the installed system. I've looked and mtab is created by anaconda. So I guess instead of writing out our own mtab, we should just make a symlink to /proc/self/mounts, but I'm not sure if it's that easy. I think Dave will know better.
Comment 2 David Lehman 2011-01-19 13:02:42 EST
Ondrej, since you maintain the setup package which currently owns /etc/mtab, I thought this might be of interest to you.

I don't know why we ever made our own mtab file in anaconda, so I have made a patch to switch to a symlink.
Comment 3 Ondrej Vasik 2011-01-19 14:24:56 EST
setup package owns the /etc/mtab, but only as ghosted file. AFAIK any userspace actions with /etc/mtab are done by util-linux package(or by pre-f15 name util-linux-ng) which owns mount binary and is maintained by Karel Zak.
Comment 4 James Laska 2011-02-08 15:26:38 EST
I don't believe this issue qualifies as a Alpha release blocker, in fact I think this might be more appropriate for the Final release.  However, I'm adding this to 'F15Alpha' so we can review the use cases that may be impacted by this bug.

Note You need to log in before you can comment on or make changes to this bug.