This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 670420 - Guest's time is not updated after the host reboot
Guest's time is not updated after the host reboot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-18 02:56 EST by Jan "Yenya" Kasprzak
Modified: 2013-01-09 18:29 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 07:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2011-01-18 02:56:56 EST
Description of problem:
In F14, when the host is rebooted, kvm guests are hibernated using /etc/init.d/libvirt-guests. The problem is that after resuming them again, their system time is not updated. The virtual rtc inside the guest is correct (according to hwclock(8)), but the system time according to date(1) is back with the time difference being the time during which the guest has been suspended.

I think the guest should be informed that it has just been resumed, and it should update its system time from the virtual rtc (and possibly do other things like renew its DHCP leases, etc.).

Apparently VMware can pass such an information to the guest using their vmware-tools.

Version-Release number of selected component (if applicable):

libvirt-0.8.3-2.fc14.x86_64
libvirt-client-0.8.3-2.fc14.x86_64
qemu-system-x86-0.13.0-1.fc14.x86_64
kernel-2.6.35.10-74.fc14.x86_64

How reproducible:
100 %

Steps to Reproduce:
1. Install F14 with libvirt and libvirt-client packages
2. Create a new VM, install F14 to it
3. Shutdown -h the host system
4. Wait several minutes and start the host system again
5. Log in to the guest system and run "hwclock" and "date"
  
Actual results:
The time of hwclock and date differs, and the difference equals to the host downtime (or guest suspend time).

Expected results:
After being resumed, guest should update its system time.


Additional info:
I am filling this under kvm, but I am not sure on which level the resume notification should be sent.
Comment 1 Jan "Yenya" Kasprzak 2011-01-18 02:57:56 EST
Additional note: this bug is probably related to the RHEL bug #629546.
Comment 2 Justin M. Forbes 2011-01-20 13:36:14 EST
What is the guest running?
Comment 3 Jan "Yenya" Kasprzak 2011-01-20 13:41:32 EST
Both guest and host is running F14. Guest OS is mentioned in "Steps to reproduce, step 2"
Comment 4 Cole Robinson 2012-05-21 07:48:33 EDT
F14 is no longer supported. Jan, if you are still affected by this bug with newer
qemu versions (fedora 16 or 17), please reopen this report and we can take it from there.

Note You need to log in before you can comment on or make changes to this bug.