Bug 670437 - Fail2ban can't start on OpenVZ host system
Fail2ban can't start on OpenVZ host system
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: fail2ban (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Miller
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-18 05:10 EST by Jakub Jedelsky
Modified: 2014-08-15 14:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: fail2ban-0.8.13-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-15 14:59:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suport for OpenVZ host server; check pid of running instance via vzpid (1013 bytes, patch)
2011-01-18 05:10 EST, Jakub Jedelsky
no flags Details | Diff

  None (edit)
Description Jakub Jedelsky 2011-01-18 05:10:28 EST
Created attachment 474013 [details]
Suport for OpenVZ host server; check pid of running instance via vzpid

Description of problem:
Fail2ban can't start on OpenVZ host server if any guest has a fail2ban instance started - because of PID check in init script.
Prepared patch for init script is added as attachment.

Version-Release number of selected component (if applicable):
0.8.4

How reproducible:
Start fail2ban on openvz host with guest running fail2ban too.
  
Actual results:
Can't start becouse of pid

Expected results:
Can start

Additional info:
Comment 1 Orion Poplawski 2014-03-17 20:12:47 EDT
I believe the getpid check is removed in 0.8.11-1.  Reopen if this is not fixed.
Comment 2 Orion Poplawski 2014-03-17 20:14:17 EDT
Ah crap, just saw this is for el5
Comment 3 Fedora Update System 2014-07-21 19:13:18 EDT
fail2ban-0.8.13-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/fail2ban-0.8.13-1.el5
Comment 4 Fedora Update System 2014-07-22 14:10:03 EDT
Package fail2ban-0.8.13-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing fail2ban-0.8.13-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1996/fail2ban-0.8.13-1.el5
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2014-07-30 15:35:39 EDT
Package fail2ban-0.8.13-2.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing fail2ban-0.8.13-2.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1996/fail2ban-0.8.13-2.el5
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-08-15 14:59:57 EDT
fail2ban-0.8.13-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.