Bug 670496 - IndexError: list index out of range
IndexError: list index out of range
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:d3d103d0b83af39c8...
: Reopened
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-01-18 08:43 EST by Gaetan Cambier
Modified: 2011-03-16 00:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-15.22-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-16 00:06:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (552.49 KB, text/plain)
2011-01-18 08:43 EST, Gaetan Cambier
no flags Details
df -h (536 bytes, text/plain)
2011-01-18 11:19 EST, Gaetan Cambier
no flags Details
grep sysimage /proc/mounts (548 bytes, text/plain)
2011-01-18 11:19 EST, Gaetan Cambier
no flags Details

  None (edit)
Description Gaetan Cambier 2011-01-18 08:43:06 EST
The following was filed automatically by anaconda:
anaconda 14.22 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/backend.py", line 147, in mountInstallImage
    free[-1][0])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 937, in run
    if self.anaconda.backend.mountInstallImage(self.anaconda, stage2img):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1730, in doInstall
    rc = self.ayum.run(self.instLog, cb, anaconda.intf)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/backend.py", line 286, in doInstall
    return anaconda.backend.doInstall(anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1190, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1211, in handleRenderCallback
    self.currentWindow.renderCallback()
IndexError: list index out of range
Comment 1 Gaetan Cambier 2011-01-18 08:43:15 EST
Created attachment 474049 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2011-01-18 10:04:31 EST

*** This bug has been marked as a duplicate of bug 640893 ***
Comment 3 David Lehman 2011-01-18 10:12:15 EST
Do you still have this system available for data collection?

If so, go to tty2 (ctl+alt+f2) and run the following commands, then post the
full output to this bug report:

  grep sysimage /proc/mounts
  df -h


Thanks.
Comment 4 Gaetan Cambier 2011-01-18 11:19:23 EST
Created attachment 474092 [details]
df -h
Comment 5 Gaetan Cambier 2011-01-18 11:19:52 EST
Created attachment 474093 [details]
grep sysimage /proc/mounts
Comment 6 Gaetan Cambier 2011-01-18 11:57:28 EST
My system i'ts  a raid software

cat /proc/mdstat

Personalities : [raid1] [raid6] [raid5] [raid4] 
md1 : active raid5 sda2[0] sdd2[4] sdc2[2] sdb2[1]
      1463609280 blocks super 1.0 level 5, 64k chunk, algorithm 2 [4/4] [UUUU]
      bitmap: 7/466 pages [28KB], 512KB chunk

md0 : active raid1 sda1[0] sdd1[3] sdc1[2] sdb1[1]
      513044 blocks super 1.0 [4/4] [UUUU]
      bitmap: 0/8 pages [0KB], 32KB chunk

unused devices: <none>

md0 : /boot 

md1 : lvm : /
Comment 7 Gaetan Cambier 2011-01-25 11:37:31 EST
I have found the solution. 

I have modified the uuid in the /etc/fstab by the path of the device and the installation is ok
Comment 8 David Lehman 2011-02-15 14:32:26 EST
Yes, the problem is that you have quotation marks around the UUIDs in /etc/fstab.
Comment 9 David Lehman 2011-02-15 14:41:13 EST
I am proposing a patch that would fix this for Fedora 15.
Comment 10 David Lehman 2011-02-15 15:51:44 EST
This bug prevents us from properly parsing an /etc/fstab that quotes the values of UUIDs and/or labels in device specifications. The fix is very low-risk and could certainly be viewed as a strengthening of the algorithms.
Comment 11 Gaetan Cambier 2011-02-16 09:05:44 EST
the quote "" is incorrect in the fstab ? 
the correct use is :  UUID=29d54a1d-75ee-4ed3-8ab2-9fb00256bb23 ???
Comment 12 David Lehman 2011-02-16 09:47:36 EST
The quote is unnecessary. Your correct use example is correct.

I have added a patch to anaconda so that we can recognize quoted UUIDs and labels. I am trying to get it into Fedora 15.
Comment 13 David Lehman 2011-03-09 14:07:37 EST
Fixed for Fedora 15 in anaconda-15.22-1.
Comment 14 Fedora Update System 2011-03-09 16:55:33 EST
anaconda-15.22-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.22-1.fc15
Comment 15 James Laska 2011-03-11 14:40:59 EST
Discussed at 2011-03-11 blocker review meeting.  This issue is fixed and available for testing in anaconda-15.22-1.  The issue has been accepted as a beta blocker.
Comment 16 Fedora Update System 2011-03-16 00:06:10 EDT
anaconda-15.22-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.