Bug 670727 - qemu discard the errors for migration failing.
qemu discard the errors for migration failing.
Status: CLOSED DUPLICATE of bug 584077
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.1
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
: Triaged
Depends On:
Blocks: 580954 615941 619846 688804 696948 698141 698496
  Show dependency treegraph
 
Reported: 2011-01-19 00:28 EST by Osier Yang
Modified: 2013-01-09 18:30 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 698496 (view as bug list)
Environment:
Last Closed: 2011-07-28 10:52:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Osier Yang 2011-01-19 00:28:06 EST
Description of problem:
libvirts use 3 URIs for migration:

1) source libvirtd URI
2) destination libvirtd URI
3) destination QEMU URI.

And if the destination QEMU URI is not specified by user, libvirt will try to execute "hostname()" on destination host to guess the hostname, and uses it to
form QEMU URI, (e.g. tcp://10.66.70.98).

So, If destination host is mis-configured, it will return a illed hostname which would not be able to address by source host, as a result, the migration will fail.

The problem here is that qemu discard the errors for migration failing (actually all of the errors related to getaddrinfo(3)/connect(2) failing?), so, libvirt can not get the exact error information for dignose log, an error like "An undefined error has occured" obviously is not what the user want to see. 

To get more info, see:
http://post-office.corp.redhat.com/mailman/private/virt-devel/2011-January/msg00239.html

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Osier Yang 2011-01-25 06:51:05 EST
another bug blocked by this problem: https://bugzilla.redhat.com/show_bug.cgi?id=619846
Comment 5 Dave Allan 2011-06-03 12:13:00 EDT
Thanks, Juan.
Comment 6 juzhang 2011-06-14 07:41:12 EDT
Hi,Juan/Osier

    would you please tell me is this issue duplicate Bug 584077 - QMP: Improve migrate command error info? seems bz584077 is key reason, libvirt call qmp.
Comment 7 Markus Armbruster 2011-07-28 10:52:24 EDT
Yes, this is the same as bug 584077.

*** This bug has been marked as a duplicate of bug 584077 ***

Note You need to log in before you can comment on or make changes to this bug.