Bug 670846 - DDNS (Dynamic DNS) updates no longer work
DDNS (Dynamic DNS) updates no longer work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-19 09:26 EST by Pim Zandbergen
Modified: 2012-07-02 12:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 10:14:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pim Zandbergen 2011-01-19 09:26:10 EST
Description of problem:

After updating from Fedora 13 to Fedora 14, dynamic updates
using the "interim" update scheme no longer work

Version-Release number of selected component (if applicable):
dhcp-4.2.0-16.P2.fc14.x86_64

How reproducible:
Always


Steps to Reproduce:
1. configure dhcpd to allow ddns on Fedora 13
2. verify dynamic updates from Windows clients are handled
3. upgrade to Fedora 14
  
Actual results:
No dynamic updates are performed
With every DHCP renewal this message is logged:
Unable to add forward map from <FQDN> to <ip-address>: not found


Expected results:
dhcp server updates DNS


Additional info:
Using wireshark, no DNS traffic is noticed between dhcpd and bind

Reverting to dhcp-4.1.1-27.P1.fc13.x86_64 fixes problem
Reverting requires removal of dhclient because of conflict

Upstream mailing list makes this referral:
https://lists.isc.org/pipermail/dhcp-users/2010-August/011886.html
Comment 1 Charlweed Hymerfan 2011-06-19 20:23:12 EDT
I don't know if this is a bug,
But I definitely get this behavior, and the same error message.
I have Fedora 15, and every attempt from all DHCP clients generate this error. The only clients that can update DNS are Windows, and I do not believe they are using DHCP at all.

Attempts at reconfiguring DHCP clients, server, and DNS have failed. Importna to note that the message is not "connection refused" or "timed out" or "permission denied" or even "file not found". The message is exactly
"not found" 
Exactly what is not found, and why, is a mystery.
Comment 2 Pim Zandbergen 2011-06-20 09:37:12 EDT
Depending on your configuration, Windows clients can either update DNS directly or through the DHCP server.

I could verify my problem is with dhcpd updating bind. I could verify that dhcpd 4.2.0 in Fedora 14 makes no attempt to update DNS, as watched using Wireshark.

The "nsupdate" utility that comes with bind-utils would work perfectly for me. I guess you should try nsupdate to verify your bind configuration.

I haven't tried dhcp 4.2.1 that comes with Fedora 15 yet. The changelog does suggest some DDNS bugs have been fixed.
Comment 3 Jiri Popelka 2012-06-26 10:14:27 EDT
Fedora 14 is no longer supported and Fedora 15 reached end of life today.
I'm sorry I haven't been able to help you with this issue.
There were some DDNS related changes in recent versions of ISC dhcp
so hopefully 4.2.4 in Fedora 17 will be better.
Give it a try and if you still see the problem feel free to reopen this BZ.
Thanks.
Comment 4 Pim Zandbergen 2012-07-02 12:59:45 EDT
No problem; I can verify the problem no longer exists in Fedora 16

Note You need to log in before you can comment on or make changes to this bug.