Bug 670885 - Unsubscribe from rhsm should throw a warning message
Summary: Unsubscribe from rhsm should throw a warning message
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Justin Harris
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2011-01-19 15:39 UTC by Bryan Kearney
Modified: 2013-07-04 21:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-24 16:18:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bryan Kearney 2011-01-19 15:39:40 UTC
When unsubscribing, if the subscription is active then a warning dialog should ask "Are you sure"?

-- bk

Comment 2 John Sefler 2011-01-19 16:21:04 UTC
For the sake of parity, does this apply to the cli too?  I hope not.

Comment 3 Bryan Kearney 2011-01-19 16:23:54 UTC
no.. i would vote just ui.

Comment 5 J.C. Molet 2011-01-20 17:14:45 UTC
User is asked "are you sure", when unregistering, but not when unsubscribing to a subscription with installed products as indicated in the description.


python-rhsm-0.94.15-1.git.0.b738ea1.el6.noarch
subscription-manager-0.93.13-1.git.4.769efa1.el6.x86_64
subscription-manager-firstboot-0.93.13-1.git.4.769efa1.el6.x86_64
subscription-manager-gnome-0.93.13-1.git.4.769efa1.el6.x86_64

Comment 6 J.C. Molet 2011-01-20 17:51:32 UTC
new build:

subscription-manager-0.93.13-1.git.6.1cac2dd.el6.x86_64
subscription-manager-firstboot-0.93.13-1.git.6.1cac2dd.el6.x86_64
subscription-manager-gnome-0.93.13-1.git.6.1cac2dd.el6.x86_64

includes the pop up window.  The pop up window happens if there are installed products or not.

In both cases, clicking yes on the pop up causes this to happen:


2011-01-20 12:47:18,672 [INFO] _request() @connection.py:146 - loading ca pem certificates from: /etc/rhsm/ca/
2011-01-20 12:47:18,677 [INFO] _load_ca_certificates() @connection.py:133 - loading ca certificate '/etc/rhsm/ca/redhat-uep.pem'
2011-01-20 12:47:18,679 [INFO] _load_ca_certificates() @connection.py:133 - loading ca certificate '/etc/rhsm/ca/candlepin-stage.pem'
2011-01-20 12:47:18,677 [INFO] _load_ca_certificates() @connection.py:133 - loading ca certificate '/etc/rhsm/ca/redhat-uep.pem'
2011-01-20 12:47:18,679 [INFO] _load_ca_certificates() @connection.py:133 - loading ca certificate '/etc/rhsm/ca/candlepin-stage.pem'
2011-01-20 12:47:18,680 [INFO] _load_ca_certificates() @connection.py:133 - loading ca certificate '/etc/rhsm/ca/fakamai-cp1.pem'
2011-01-20 12:47:18,681 [INFO] _request() @connection.py:148 - work in insecure mode ?:True
2011-01-20 12:47:20,145 [INFO] _request() @connection.py:176 - status code: 404
2011-01-20 12:47:20,149 [ERROR] handle_gui_exception() @utils.py:40 - No such consumer: None
Traceback (most recent call last):
  File "/usr/share/rhsm/gui/mysubstab.py", line 81, in _on_unsubscribe_prompt_response
    self.backend.uep.unbindBySerial(self.consumer.uuid, serial)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 400, in unbindBySerial
    return self.conn.request_delete(method)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 211, in request_delete
    return self._request("DELETE", method)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 177, in _request
    self.validateResponse(result)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 196, in validateResponse
    parsed['displayMessage'])
RestlibException: No such consumer: None

Comment 7 Justin Harris 2011-01-21 19:12:02 UTC
I cannot reproduce this error on my setup.  Can you either try again or give some more detail on how to reproduce?

Comment 8 J.C. Molet 2011-01-24 16:18:41 UTC
I cannot reproduce this anymore either.  I guess I'll chalk this one up to the server errors we were having that day.


Note You need to log in before you can comment on or make changes to this bug.