This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 67089 - mutt segfault on terminal larger than 256 columns
mutt segfault on terminal larger than 256 columns
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mutt (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-19 16:27 EDT by Matthew Galgoci
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-27 22:26:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Galgoci 2002-06-19 16:27:56 EDT
If the terminal that mutt is running is beyond 256 columns, mutt will
segfault.

Happens every time. 

In fact, it happens on RHL 7.0, 7.1, and 7.2 as well as 7.3

1) Open an xterm

2) start mutt

3) resize the window well beyone, 256 columns, say to 262 columns.

4) watch mutt segfault

Lather, rinse, repeat

Mutt also will segfault immediately if it is started in a terminal that is
wider than 256 columns.
Comment 1 Matthew Galgoci 2003-02-27 22:26:50 EST
This is fixed in current. Cannot reproduce this on Phoebe

Note You need to log in before you can comment on or make changes to this bug.