Bug 670912 - Unable to provision system. Web UI throws "500 Internal error"
Unable to provision system. Web UI throws "500 Internal error"
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
15
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Dan Callaghan
: Reopened
: 573131 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-19 11:35 EST by Jan Ščotka
Modified: 2012-09-13 10:56 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-09 20:01:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Ščotka 2011-01-19 11:35:03 EST
Description of problem:
I've tried to provision an system https://beaker.engineering.redhat.com/action_provision?prov_install=41755&ks_meta=&koptions=&koptions_post=&reboot=on&id=2875

what I've created day ago (propably everything should be setup, but it still doesn't work)
I'm not sure if everything is set up properly, but is isn't a problem.
Problem is, that it throws only: 
<body>
        <h2>500 Internal error</h2>
        <p>The server encountered an unexpected condition which prevented it from fulfilling the request.</p>

        <pre id="traceback"></pre>
    <div id="powered_by">
    <span>Powered by <a href="http://www.cherrypy.org">CherryPy 2.3.0</a></span>
    </div>
    </body></html>

Version-Release number of selected component (if applicable):
system x86-64-m01.lab.eng.brq.redhat.com in inventory

How reproducible:
100% 

Steps to Reproduce:
1. try to provision with any distro


Actual results:
only general error message

Expected results:
some useful error (if anything is not set up, show what's wrong) in other case install system without problem.

Additional info:
Comment 2 Vadim Grinco 2011-01-20 07:01:52 EST
It was caused by duplicate system profiles on cobbler after renaming a system in beaker.

Can be reproduced like that:
1. Pick any system in beaker, provision it
2. Change its name in DNS and rename it in beaker
3. Provision the system again after it was renamed

Solution: 
Beaker should let cobbler know to delete the system profile for a system which has been renamed.

I'll reopen this bug.
Comment 3 Jan Ščotka 2011-01-20 08:00:04 EST
I didn't know what exactly caused a problem, it sounds logically, after seeing that there is exception with dual ip adresses.

Also "500 Internal error" isn't good result, I suggest in similar cases put there somethig like "else/finally" option to show something like:
" unable to provision the system, please send ticket to beaker queue. " instead of http server internal error.
   regards
   Honza
Comment 4 Raymond Mancy 2011-01-20 17:52:32 EST
Thanks Vadim, I'll take a look.
Comment 6 Dan Callaghan 2011-02-01 22:21:19 EST
*** Bug 573131 has been marked as a duplicate of this bug. ***
Comment 8 Dan Callaghan 2011-02-09 20:01:19 EST
Beaker 0.6.4 has been released.

Note You need to log in before you can comment on or make changes to this bug.