Bug 67100 - it depends on python, but no dependency is built into the package
Summary: it depends on python, but no dependency is built into the package
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-switchmail   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-20 00:29 UTC by Florin Andrei
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-20 00:30:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florin Andrei 2002-06-20 00:29:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
The package allows to be installed without verifying that Python is already
installed. When you try to run redhat-switchmail-nox, it fails because there's
no python interpreter

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install 7.3 "custom" but disable all package categories
2.install redhat-switchmail
3.try to run redhat-switchmail-nox
	

Actual Results:  it fails, saying there's no python interpreter available

Expected Results:  when installing the package, it should refuse to be
installed, saying it needs python as a package dependency

Additional info:

perhaps you should create two packages, one with the GUI, the other with the
-nox utility, each one with its own dependencies

Comment 1 Ngo Than 2002-06-20 09:31:27 UTC
it's now fixed in 0.5.7-1.


Note You need to log in before you can comment on or make changes to this bug.