Bug 67103 - upgrade fails when /etc/fstab contains fstype of auto
upgrade fails when /etc/fstab contains fstype of auto
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-19 21:28 EDT by Ben L. Perkins
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-26 12:56:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben L. Perkins 2002-06-19 21:28:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
Upgrade of a RH 7.2 system to RH 7.3 fails if the system is spread across
multiple partitions and the type of some of the partitions is listed as "auto"
in /etc/fstab.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start with a multi-partition RH 7.2 system to be upgraded
2. Have a separate /var and/or /usr partition
3. Mark the fstype of those partitions as "auto" in /etc/fstab
4. Boot from RH 7.3 cds and start gui installer
5. Accept defaults until asked whether to install or upgrade
6. Choose upgrade and select the proper root filesystem (if needed)
7. Continue to accept defaults until the error happens

Actual Results:  If /var is not part of /, the symptom is an error dialog saying
the following:

"Rebuild of RPM database failed.
You may be out of disk space?"  

If you toggle over to ctrl-alt-f1, you see the following:

"error: creating directory /mnt/sysimage/var/lib/anaconda-rebuilddb102452275: No
such file or directory"

This occurs because /mnt/sysimage/var/ isn't mounted.  In fact, a df on
ctrl-alt-f2 shows that none of the secondary file systems of type "auto" have
been mounted.  Only the root file system.  Once you acknowledge the error,
anaconda terminates the install and reboots.

If /var is part of /, then the install proceeds to the phase of installing RPMs.
 In my case, it finally failed because it attempted to install almost 3 gigs
worth of data onto a 300 Meg / partition, rather than mounting /usr as it should
have.  Subdirectories are created under the mountpoints on / instead of the file
systems being mounted.  Eventually the installer locks up due to lack of
diskspace and ctrl-alt-delete is required, leaving you with a broken system.

Expected Results:  The installer should have mounted /var, /usr, etc. and
performed the upgrade normally.  As a second choice, the installer should warn
you that fstype of "auto" isn't supported and refuse to continue.

Additional info:
Comment 1 Jay Turner 2002-06-20 11:26:54 EDT
Have actually entered a bug against Rawhide code, so hopefully it will get fixed
there.
Comment 2 Jeremy Katz 2003-02-26 12:56:34 EST
We sniff filesystems which are marked as auto in Red Hat Linux 8.0 or later to
mount them as the correct type during the upgrade.

Note You need to log in before you can comment on or make changes to this bug.