Bug 671053 - Stand-alone sets can't find book Common Content
Stand-alone sets can't find book Common Content
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Linux
low Severity medium
: ---
: ---
Assigned To: Ruediger Landmann
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-19 23:34 EST by Laura Bailey
Modified: 2011-04-07 22:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-07 22:52:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laura Bailey 2011-01-19 23:34:53 EST
Description of problem:

Attempting to build a standalone set results in:

FATAL ERROR: XInclude:1604 in Conceptual_Guide/Book_Info.xml on line 28: could 
not load Conceptual_Guide/Common_Content/Legal_Notice.xml, and no fallback was 
found
at /usr/bin/publican line 672

for all common content in all books in the set. Common Content seems to be level-specific - if I change paths from "Common_Content/file" to "../Common_Content/file", it works.

Example, with this modification: https://svn.devel.redhat.com/repos/ecs/Staff/lbailey/Set_Template/


Version-Release number of selected component (if applicable):
publican-2.5-1.fc13.noarch


How reproducible:
Every time.
  

Expected results:
Common Content path should not need to be modified in books.
Comment 1 Jeff Fearn 2011-04-07 22:52:55 EDT
This isn't a bug, the common content is only added once, at the top level, the only other way to do it would be to add it multiple times which would be inefficient.

Note You need to log in before you can comment on or make changes to this bug.