Bug 67106 - file list expansions using [M-N] ranges produces wrong results
Summary: file list expansions using [M-N] ranges produces wrong results
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bash   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-20 03:23 UTC by ellson
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-20 14:16:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ellson 2002-06-20 03:23:23 UTC
Description of Problem:
"ls [M-N]" should list only file "M" and "N" if they exist, not "m" or "n"


Version-Release number of selected component (if applicable):
bash-2.05a-14.i386.rpm

How Reproducible:
100%

Steps to Reproduce:
1. touch m M n
2. ls [M-N]
3. 

Actual Results:
M n

Expected Results:
M

Additional Information:
Problem does not exist in bash-2.05a-13 from Redhat-7.3

Comment 1 Bernhard Rosenkraenzer 2002-06-20 11:30:31 UTC
This is the correct result.
Bash is i18n aware these days.
If you don't like it, use LC_COLLATE=C

Comment 2 ellson 2002-06-20 11:59:50 UTC
I think that LC_COLLATE=C should be the default so that the behavior of
shell scripts and Makefiles don't suddenly change.

Comment 3 ellson 2002-06-20 14:15:54 UTC
LC_COLLATE=C does restore reasonable behavior, but 
I can't see the logic of the new changed collate sequence.  It still looks like
a bug to me.

In the example:
   touch m M n 
   ls [M-N]
why is "M" listed but not "m"




Note You need to log in before you can comment on or make changes to this bug.