This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 671076 - configurable period of 99-raid-check
configurable period of 99-raid-check
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
15
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-20 03:48 EST by Jan "Yenya" Kasprzak
Modified: 2011-04-15 17:11 EDT (History)
1 user (show)

See Also:
Fixed In Version: mdadm-3.1.5-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-15 17:11:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2011-01-20 03:48:21 EST
Description of problem:
I have a system with 24 2TB disks in RAID-10 volume. Its raid check takes 11 hours on a totally idle system with manually increased /sys/block/md*/md/sync_speed_{min,max}, and under moderate load it takes over a day. For me it is not feasible to have the array being checked weekly.

I would suggest making /etc/cron.weekly/99-raid-check a script in /usr/sbin,
and a /etc/cron.d/raid-check crontab with the %config attribute. It would allow users to set up their own prefered frequency and start time of raid checks.

I think for 99-raid-check we don't need the benefits of anacron, which /etc/cron.weekly provides. Quite opposite is true: anacron makes the problem worse, because 99-raid-check is started at random times, and after the reboot it can be started even outside the weekend.
 
Version-Release number of selected component (if applicable):
mdadm-3.1.3-0.git20100804.2.fc14.x86_64
Comment 1 Doug Ledford 2011-03-25 15:56:55 EDT
Good suggestion.  This is going into the mdadm-3.1.4 package.  Please test to make sure it meets your needs.
Comment 2 Fedora Update System 2011-03-28 11:45:11 EDT
mdadm-3.1.5-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdadm-3.1.5-1.fc15
Comment 3 Fedora Update System 2011-03-28 23:33:57 EDT
Package mdadm-3.1.5-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mdadm-3.1.5-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mdadm-3.1.5-1.fc15
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2011-03-31 15:44:36 EDT
Package mdadm-3.1.5-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mdadm-3.1.5-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mdadm-3.1.5-2.fc15
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-04-15 17:11:02 EDT
mdadm-3.1.5-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.