Bug 671082 - libguestfs does not work with kernel-rt
libguestfs does not work with kernel-rt
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks: 670942 699984
  Show dependency treegraph
 
Reported: 2011-01-20 04:10 EST by Richard W.M. Jones
Modified: 2011-07-22 11:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 670942
Environment:
Last Closed: 2011-07-22 11:17:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2011-01-20 04:10:15 EST
+++ This bug was initially created as a clone of Bug #670942 +++

Description of problem:
Currently kernel-rt (from MRG packages) does not work with libguestfs (i.e. libguestfs-test-tool fails (or most probably kernel-rt breaks libguestfs). libguestfs always chooses the latest available kernel, maybe it should not use any kernel-rt.

Version-Release number of selected component (if applicable):
kernel-rt-2.6.33.7-rt29.45
python-libguestfs-1.2.7-1.el5.8
libguestfs-1.2.7-1.el5.8

--- Additional comment from ltoscano@redhat.com on 2011-01-19 12:54:44 EST ---

Created attachment 474330 [details]
Output from libguestfs-test-tool

--- Additional comment from ltoscano@redhat.com on 2011-01-19 13:00:41 EST ---

See also bz670943.

--- Additional comment from rjones@redhat.com on 2011-01-19 13:03:27 EST ---

Can you do:

ls -l /boot

--- Additional comment from ltoscano@redhat.com on 2011-01-19 13:08:47 EST ---

# ls -l /boot/
total 21928
-rw-r--r-- 1 root root   67214 Jan  4 13:47 config-2.6.18-238.1.1.el5
-rw-r--r-- 1 root root   67210 Dec 19 14:36 config-2.6.18-238.el5
-rw-r--r-- 1 root root   91391 Oct 12 15:46 config-2.6.33.7-rt29.45.el5rt
drwxr-xr-x 2 root root    1024 Jan 19 12:22 grub
-rw------- 1 root root 3485972 Jan 19 11:04 initrd-2.6.18-238.1.1.el5.img
-rw------- 1 root root 3486015 Jan 19 10:10 initrd-2.6.18-238.el5.img
-rw------- 1 root root 3483384 Jan 19 12:22 initrd-2.6.33.7-rt29.45.el5rt.img
drwx------ 2 root root   12288 Jan 19 05:06 lost+found
-rw-r--r-- 1 root root  113923 Jan  4 13:47 symvers-2.6.18-238.1.1.el5.gz
-rw-r--r-- 1 root root  113923 Dec 19 14:36 symvers-2.6.18-238.el5.gz
-rw-r--r-- 1 root root 1260254 Jan  4 13:47 System.map-2.6.18-238.1.1.el5
-rw-r--r-- 1 root root 1260254 Dec 19 14:36 System.map-2.6.18-238.el5
-rw-r--r-- 1 root root 1802210 Oct 12 15:46 System.map-2.6.33.7-rt29.45.el5rt
-rw-r--r-- 1 root root 2094844 Jan  4 13:47 vmlinuz-2.6.18-238.1.1.el5
-rw-r--r-- 1 root root 2094684 Dec 19 14:36 vmlinuz-2.6.18-238.el5
-rw-r--r-- 1 root root 2895200 Oct 12 15:46 vmlinuz-2.6.33.7-rt29.45.el5rt

--- Additional comment from rjones@redhat.com on 2011-01-19 14:05:29 EST ---

Thanks.

The problem is the -rt kernel is compiled without support
for any virtio (in particular virtio-net and virtio-blk).
This is not particularly surprising given the target of
-rt kernels is not virt.

*Luigi*, can you confirm that virtio is not enabled by doing:

grep VIRTIO /boot/config-2.6.33.7-rt29.45.el5rt

Assuming I am correct about virtio, it looks like there are
three possible ways to solve this:

(1) Ignore -rt kernels (as we currently ignore xen kernels).

(2) Try to persuade the developers to enable virtio in these
    kernels.

(3) Change libguestfs in RHEL 5.6 to use non-virtio devices.
    A similar change would be needed in RHEL 6.

I favour (2) at the moment.
Comment 1 Richard W.M. Jones 2011-07-22 11:09:36 EDT
I've added this patch to febootstrap which allows
kernels to be selected by setting the FEBOOTSTRAP_KERNEL
environment variable:

http://git.annexia.org/?p=febootstrap.git;a=commitdiff;h=ad47b1cf5010721fc12f814a1b3275361fef6493

Note You need to log in before you can comment on or make changes to this bug.