Bug 671182 - Missing Requires of pyxdg
Summary: Missing Requires of pyxdg
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: radiotray
Version: 13
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jean-Francois Saucier
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-20 17:27 UTC by hannes
Modified: 2016-04-02 06:39 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-02-03 20:20:58 UTC


Attachments (Terms of Use)

Description hannes 2011-01-20 17:27:07 UTC
Description of problem:
I wasn't able to start radiotray after I did a yum install radiotray the following error occured:
radiotray
Traceback (most recent call last):
  File "/usr/bin/radiotray", line 12, in <module>
    os.chdir(workdir)
OSError: [Errno 2] No such file or directory: '/usr/bin/src'

After installatio of pyxdg everything works as expected.

Comment 1 Michael Schwendt 2011-01-20 18:38:39 UTC
Confirmed. Actually, the message about /usr/bin/src is misleading crap. It's only that way because the /usr/bin/radiotray wrapper hides the real exception and then does something that doesn't make sense for an RPM package install. The real exception is this:

Traceback (most recent call last):
  File "./radiotray", line 7, in <module>
    from radiotray import radiotray
  File "/usr/lib/python2.6/site-packages/radiotray/radiotray.py", line 5, in <module>
    from RadioTray import RadioTray
  File "/usr/lib/python2.6/site-packages/radiotray/RadioTray.py", line 24, in <module>
    from SysTray import SysTray
  File "/usr/lib/python2.6/site-packages/radiotray/SysTray.py", line 38, in <module>
    from lib.common import APPNAME, APPVERSION, APP_ICON_ON, APP_ICON_OFF, APP_ICON_CONNECT
  File "/usr/lib/python2.6/site-packages/radiotray/lib/common.py", line 5, in <module>
    from xdg.BaseDirectory import xdg_data_home
ImportError: No module named xdg.BaseDirectory

Comment 2 Jean-Francois Saucier 2011-01-21 21:37:33 UTC
I will fix this in the next release, thanks for pointing this missing requires to me.

Comment 3 Fedora Update System 2011-01-24 17:26:12 UTC
radiotray-0.6.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/radiotray-0.6.3-1.fc14

Comment 4 Fedora Update System 2011-01-24 17:37:48 UTC
radiotray-0.6.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/radiotray-0.6.3-1.fc13

Comment 5 Fedora Update System 2011-01-25 20:56:29 UTC
radiotray-0.6.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update radiotray'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/radiotray-0.6.3-1.fc14

Comment 6 Fedora Update System 2011-02-03 20:20:44 UTC
radiotray-0.6.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-02-03 20:21:39 UTC
radiotray-0.6.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 johomes 2016-04-02 06:39:17 UTC
 It's only that way because the /usr/bin/radiotray wrapper hides the real exception and then does something that doesn't make sense for an RPM package install. The real exception is this: http://www.qwiknumbers.com/sky-customer-services

Traceback (most recent call last):
  File "./radiotray", line 7, in <module>
    from radiotray import radiotray
  File "/usr/lib/python2.6/site-packages/radiotray/radiotray.py", line 5, in


Note You need to log in before you can comment on or make changes to this bug.