This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 671257 - compizconfig-backend-gconf 0.9.2.2-0.1.git86d949fad4 not built with $RPM_OPT_FLAGS
compizconfig-backend-gconf 0.9.2.2-0.1.git86d949fad4 not built with $RPM_OPT_...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Adam Williamson
Fedora Extras Quality Assurance
: Regression, Triaged
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2011-01-20 16:36 EST by Ville Skyttä
Modified: 2011-01-23 23:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-23 23:25:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2011-01-20 16:36:14 EST
See gcc commands in the build log, and note that -debuginfo contains no sources.

This looks like a regression, 0.8.4-4 seems to have been built with $RPM_OPT_FLAGS.
http://kojipkgs.fedoraproject.org/packages/compizconfig-backend-gconf/0.8.4/4.fc14/data/logs/x86_64/build.log
http://kojipkgs.fedoraproject.org/packages/compizconfig-backend-gconf/0.9.2.2/0.1.git86d949fad4.fc15/data/logs/x86_64/build.log
Comment 1 Adam Williamson 2011-01-20 18:24:19 EST
hum, some of the commands get them, some don't...I'll look into it.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Matěj Cepl 2011-01-21 11:39:36 EST
This bug has been triaged
Comment 3 Adam Williamson 2011-01-23 21:09:25 EST
so, it turns out this is wider - actually compiz itself builds without cflags, and the same for all compiz stuff that uses cmake.

it was due to a bug in a cmake file that compiz itself and all dependent bits include, which set CMAKE_C_FLAGS without including $CMAKE_C_FLAGS to keep whatever flags were previously set, so it overrode any you passed in.

I'm fixing this in compiz -11 and will then rebuild all the other packages, and they should then pick up the cflags correctly. I've sent the patch upstream to Sam. Thanks for the catch!
Comment 4 Adam Williamson 2011-01-23 23:25:20 EST
okay, this should be fixed now: I've rebuilt all compiz cmake bits (I think) and checked the cflags were correctly used. I also checked the debuginfo for backend-gconf is there. thanks again for the report.

Note You need to log in before you can comment on or make changes to this bug.